Présentation de Beyond Compare

Bienvenue à Beyond Compare

Beyond Compare est un utilitaire de comparaison d'objets. Ces objets sont des fichiers texte, des dossiers, des archives zip, des sites FTP, etc. Utilisez-le pour gérer le code source, conserver les dossiers synchronisés, comparer les sorties de programmes et valider les copies de CD.

Bien qu'il supporte des fonctions automatiques, le but principal de Beyond Compare est de vous aider à analyser les différences en détail, et à les apparier entre elles. Il dispose d'une large gamme de fonctions de fichier et de texte.

Ses principaux composants sont le Visualiseur de Dossier côte-à-côte, et les Visualiseurs de Fichier côte-à-côte.


L'Assistant de Comparaison

L'Assistant de Comparaison est architecturé pour vous guider dans les divers scénarios de comparaison. Pour exécuter l'assistant, ouvrez le menu Session et cliquez sur Nouvelle session [image]. Ou bien, cliquer sur Assistant de Comparaison dans la boîte de dialogue Ouvrir.

Suivez les instructions et entrez les informations qui concernent vos besoins spécifiques. Vous pouvez sauter des champs si vous n'êtes pas sûr de leur signification, puisque tout peut être modifié plus tard. Considérez l'assistant comme un modèle pratique pour une nouvelle session de comparaison.


Vue d'Ensemble des Sessions

Sessions

La spécification primaire pour comparer des structures de dossiers est le couple de dossiers de base étant comparés, tels que C:\Alpha et C:\Bêta, ou peut-être \\Developpement\SiteWebAcme et ftp://ftp.acme.com. Il y a toutefois d'autres paramètres à considérer. Par exemple, vous pouvez restreindre la comparaison à certains types de fichiers, ou ignorer certaines différences et vous concentrer sur d'autres.

Beyond Compare se rappelle des différents paramètres d'une session. Ainsi, vous pouvez revenir à la même comparaison jour après jour, vous pouvez sauvegarder des sessions avec un nom descriptif. Des sessions sauvegardées peuvent être très utiles, mais vous pouvez également les ignorer. La session <sans titre> conserve la trace de votre dernière comparaison de dossiers qui n'a pas été explicitement sauvée.

Rubriques relatives
Plus d'informations sur les Sessions
Gérer les Sessions


Critères de Comparaison

Lorsque vous y réfléchissez, il y a plusieurs façons de comparer les dossiers et les fichiers.

Si vous jetez un oeil à ce qui a changé entre deux dossiers, il peut être suffisant de regarder uniquement les dates et les tailles des fichiers. Si vous voulez valider une copie de CD, alors une comparaison de chaque fichier octet par octet est importante. Si vous comparer les versions des codes source, peut-être que vous considérerez uniquement les modifications importantes, et ignorerez les différences d'espaces blancs ou les commentaires.

La définition des Critères de Comparaison détermine comment une session doit comparer les dossiers dans son ensemble. Les critères incluent les dates/heures, les tailles, les attributs et les contenus des fichiers.

Ces critères sont utilisés pour comparer les fichiers, et non pas les dossiers directement. Par exemple, la date/heure d'un dossier n'affecte pas la comparaison. Les dossiers sont comparés en agrégeant les comparaisons des fichiers entre eux.

Certains états d'un fichier peuvent être déterminés rapidement, tandis que d'autres peuvent prendre un certain temps. Les systèmes de fichiers offrent typiquement un accès rapide aux noms, tailles et dates/heures (date et heure de dernière modification) des fichiers. Mais pour obtenir le CRC d'un fichier, le fichier entier a besoin d'être lu. Gardez cela en mémoire lorsque vous sélectionnez des critères de comparaison de dossiers.

Voir aussi
Détails des Critères
Comment définir les critères de comparaison


Vue d'Ensemble des Filtres

Une stratégie importante de comparaison des dossiers est d'éliminer ce qui n'est pas important. Beyond Compare possède deux mécanismes de filtrage : les Filtres de Fichiers et les Filtres d'Affichage.

Les Filtres de Fichiers vous permettent de cacher les fichiers ou les dossiers en se basant sur leur nom ou leur extension. Vous pouvez également cacher les fichiers qui sont plus anciens qu'une limite de date et de d'heure particulière, qui sont plus grands ou plus petits qu'une taille particulière, ou qui ont certains attributs.

Les Filtres d'Affichage vous permettent de cacher des items en se basant sur la façon de comparer. Par exemple, sélectionner Uniquement les différences [image] cache les items qui concordent. Les Filtres de Fichiers étant habituellement statiques lors du déroulement d'une session, un utilisateur commute souvent entre les Filtres d'Affichage pour mieux comprendre la comparaison.

En général, les dossiers sont intéressants à cause de leur contenu. Les dossiers disparaissent de la vue s'ils ne contribuent pas à la comparaison. Par exemple, si vous sélectionnez Uniquement les différences, les dossiers qui ne contiennent aucun fichier différent seront cachés. C'est particulièrement utile si vous avez beaucoup de dossiers mais peu de différences.

Voir également
Comment utiliser les Filtres de Fichiers
Comment utiliser les Filtres d'Affichage


Règles de Comparaison de Fichiers

Les Règles de Comparaison de Fichiers sont des règles que vous associez avec différents types de fichier. A chaque jeu de règles est attribué un nom unique (par exemple "Source C++" ou "Source Delphi") ainsi que des extensions appropriées de fichier (par exemple *.cpp,*.h ou *.pas,*.dfm,*.dpr). Des paramètres supplémentaires définissent les tabulations, distinguent les textes importants des non importants, et assignent des poids à certaines lignes pour aider au processus d'alignement.

Les règles contrôlent principalement comment le Visualiseur de Fichier traitera vos fichiers, mais peut également affecter comment le Visualiseur de Dossier comparera le contenu des fichiers. Si vous utilisez la comparaison de contenu basée sur des règles, alors le Visualiseur de Dossier limitera l'affichage uniquement aux fichiers qui ont des différences importantes.

Voir également
Gestion des Règles
Comparaison du Contenu Basée sur des Règles


Vue d'Ensemble du Visualiseur de Dossier

Le Visualiseur de Dossier compare deux structures de dossiers côte-à-côte, dans une variation du style familier de l'Explorateur. Cette vue peut être composée de dossier de votre disque dur ou réseau, mais également d'un site FTP, une archive zip, ou un Instantané pris auparavant. Tous ceux-ci ont une structure de dossier -- des dossiers et des sous-dossiers contenant des fichiers -- et que Beyond Compare traite de manière équivalente.

Le Visualiseur de Dossier vous apporte des outils (tels que les filtres et les critères de comparaison) pour mieux comprendre les différences, ainsi que des commande pour appareiller les différences (copie, déplacement, suppression, etc.).

Voir également
Sélectionner les dossiers de base
Comprendre l'affichage
Contrôler l'affichage
Sélectionner des items
Actions
Gérer des sessions


Sélectionner les Dossiers de Base

Tapez le chemin d'accès pour chaque dossier de base dans les zones de saisie de texte de gauche et de droite, et tapez ENTRÉE ou cliquez sur le bouton On y va [image].

en plus des dossiers normaux, les dossiers de base peuvent être des sites FTP, des fichiers zip ou des Instantanés.

Vous pouvez également utiliser les contrôles de la barre d'outils pour charger les dossiers de base :

Icône | Légende | Signification
 | On y va | Accepte l'entrée saisie
 | Balayer | Recherche un dossier, un site FTP, un fichier zip ou un Instantané
 | Niveau supérieur | Sélectionner le dossier de base un niveau au-dessus de l'actuel
 | Précédent | Aller en arrière vers les précédents dossiers de base sélectionnés
 | Suivant | Aller en avant vers les précédents dossiers de base sélectionnés
 | Permuter les côtés | Permute les dossiers de base

Vous pouvez également sélectionner un ou deux dossiers à partir du contenu de l'affichage du Visualiseur de Dossier, et utiliser le choix Positionner comme répertoire de base.

Voir également
Spécification FTP


Comprendre l'Affichage du Visualiseur de Dossier

Le corps de la fenêtre principale de comparaison de dossiers affiche la structure des deux dossiers côte-à-côte. Dès que la comparaison est chargée, les items sont colorés en se basant sur les paramètres des Critères de Comparaison. Les couleurs principales ainsi que leur signification sont :

Couleur | Signification
Noir | Égalité
Rouge | Nouveau ou différence
Gris | Plus ancien
Bleu | Orphelin (n'existe pas de l'autre côté)

Dans l'exemple suivant, le fichier du côté droit est coloré en rouge pour indiquer qu'il est plus récent. L'icône dans la colonne centrale [image] montre que la comparaison du contenu a trouvé des différences.

Les dossiers sont colorés pour vous indiquer leur contenu. Par exemple, la comparaison ci-dessous vous fait savoir que le dossier contient au moins un fichier plus récent du côté droit que du côté gauche, et que les deux côtés ont au moins un fichier orphelin.

Les dossiers peuvent apparaître transparents lorsque vous démarrez la comparaison. Ceci à cause du fait que le balayage automatique est effectif, mais que la tâche de fond du traitement de balayage n'a pas encore traité ces dossiers. Ils changeront de couleur dès que le traitement sera terminé.

Un dossier sera jaune si le balayage automatique n'est pas effectif, et si vous n'avez pas encore ouvert le dossier. Une fois le dossier ouvert manuellement (et peut-être également ses sous-dossiers), il sera coloré de façon appropriée.

Voir également
Plus d'Informations sur les Couleurs de Dossier
Comment Autoriser/Interdire le Balayage Automatique

Dans le bas de l'affichage est le panneau de journalisation qui montre l'historique des opérations exécutées. Pour le cacher, sélectionnez Journal (Log) du menu Voir. Cliquez sur le bouton droit dans le journal pour les autres options sur le journal, telles que Effacer les messages et Sauver vers le fichier.


Contrôle de l'Affichage du Visualiseur de Dossiers

Sélectionner un Filtre d'affichage afin de limiter la vue à certains résultats de comparaison tels que Uniquement les différences [image], ou Non orphelins [image] .

Pour trier l'affichage de comparaison de dossiers, cliquez sur l'entête de la colonne correspondante. Un affichage type a les colonnes nom de fichier, taille et dernière modification. Pour ajouter ou enlever des colonnes, cliquez avec le bouton droit dans la zone des entêtes. Si vous autorisez l'Extension, l'extension du fichier (type de fichier) sera déplacée dans sa propre colonne. C'est très utile pour trier les fichiers par extension.

Les autres items du menu Voir vous aident à manipuler l'affichage du Visualiseur de Dossier :

Icône | Légende | Pour exécuter cette action
 | Supprimer les filtres | Affiche les fichiers et dossiers normalement cachés de la vue (suite aux filtres de fichiers ou au filtre d'affichage). Les fichiers et les dossiers qui étaient cachés apparaissent colorés en turquoise (bleu-vert).
 | Toujours montrer les dossiers | Affiche toujours les dossiers, même lorsque leur contenu ne contribue pas à la comparaison.
 | Ignorer les Différences non importantes | Après une comparaison de contenu, traite les fichiers qui n'ont que des différences peu importantes comme des égalités.
 | Étendre tout | Ouvre tous dossiers et sous-dossiers.
 | Compacter tout | Ferme tous les dossiers.
 | Rafraîchir | Rafraîchit l'affichage des dossiers.
 | Rafraîchir complètement | Recharge la comparaison.

Pour changer l'apparence de l'affichage, ouvrez le menu Outils et cliquez sur Options. Dans la page Visualiseur de Dossier -> Couleurs, éditez les couleurs comme bon vous semble. Dans la page Polices, vous pouvez changer la police de caractères utilisée dans le Visualiseur de Dossier.


Sélectionner des Items dans le Visualiseur de Dossier

Cliquez sur un item de n'importe quel côté de l'affichage pour le sélectionner. Vous pouvez cliquer dans la colonne centrale pour sélectionner les deux côtés à la fois. Gardez enfoncée la touche CTRL et cliquez pour ajouter des items à votre sélection. Pour sélectionner une suite d'items, pressez le bouton de la souris sur le premier item, glissez vers le dernier, et relâchez le bouton. Si vous glisser au-dessus de la colonne du milieu, les items des deux côtés seront sélectionnés.

L'idée est de pouvoir sélectionner des fichiers et dossiers spécifiques d'un ou des deux côtés afin d'exécuter certaines actions de comparaison.

Exemple
Pour comparer des fichiers avec le même nom, cliquez sur le premier, gardez la touche CTRL appuyée et cliquez sur le second, ensuite sélectionnez l'action de comparaison.

Pour sélectionner tous les items, choisissez Sélectionner tout [image] dans le menu Éditer (ou Sélectionner tous les fichiers pour sélectionner les fichiers mais pas les dossiers). Pour modifier la sélection vers un seul côté, tenez appuyée la touche MAJUSCULES, et cliquez sur la touche Flèche à Droite ou Flèche à gauche.


Actions

Dès que vous avez des items sélectionnés, vous pouvez faire différentes actions dessus. Si vous avez sélectionné un dossier, des actions telles que la copie ou la suppression sera appliqué au dossier et à tout son contenu (visible ou non).

Les actions peuvent être sélectionnées à partir du menu Action, en cliquant avec le bouton droit sur une sélection, ou en utilisant les boutons de la barre d'outils.

Icône | Légende | Pour exécuter cette action
 | Comparer dans le visualiseur | Compare les fichiers côte-à-côte dans le visualiseur associé
 | Comparer à... | Vous permet de sélectionner un fichier, et ensuite de cliquer sur un deuxième afin de les comparer dans le visualiseur
 | Ouvrir avec | Ouvre les fichiers sélectionnés dans une application externe
 | Comparer les Contenus | Compare le contenu des fichiers, dossiers sélectionnés
 | Copier | Copie les fichiers, dossiers sélectionnés
 | Copier vers un Dossier | Copie les fichiers, dossiers sélectionnés vers un autre dossier
 | Déplacer | Déplace les fichiers, dossiers sélectionnés
 | Supprimer | Supprime les fichiers, dossiers sélectionnés
 | Renommer | Renomme les fichiers, dossiers sélectionnés
 | Attributs | Change les attributs des fichiers, dossiers sélectionnés
 | Modifier les dates/heures | Change les dates/heures des fichiers, dossiers sélectionnés
 | Exclure | Exclut ce fichier ou type de fichier de la session
 | Rapport des différences entre fichiers | Imprime ou sauvegarde l'état des différences entre fichiers
 | Nouveau Dossier | Crée un nouveau dossier
 | Propriétés | Affiche les propriétés du fichier ou dossier sélectionné
 | Synchroniser vers la droite | Met à jour automatiquement, ou duplique les dossiers
 | Synchroniser vers la gauche | Met à jour automatiquement, ou duplique les dossiers
 | Synchronisation spécifique | Met à jour automatiquement, ou duplique les dossiers
 | Sauver l'Instantané | Crée un fichier Instantané
 | Rapport de comparaison des dossiers | Imprime ou sauvegarde l'état de comparaison des dossiers


Gérer des Sessions

Les barres d'outils Sessions et Filtres fournissent des accès aisés aux paramètres généraux de sessions :

Pour rappeler une session sauvegardée, sélectionnez-là dans la liste déroulante. Vous pouvez aussi la sélectionner à partir des sessions les plus récentes listées dans le menu Session.

Pour accéder aux paramètres de toutes les sessions en un seul dialogue, sélectionnez Gestionnaire de sessions [image] dans le menu Session.

Ce menu Session contient :

Icône | Légende | Signification
 | Nouvelle session | Démarre une nouvelle session en utilisant l'Assistant de Comparaison
 | Nouvelle session vide | Démarre une nouvelle session avec les paramètres par défaut
 | Ouvrir | Rappelle une session sauvegardée
 | Sauver | Sauvegarde les paramètres actuels
 | Sauver sous | Sauvegarde les paramètres actuels sous un nouveau nom
 | Supprimer | Supprime la session actuelle
 | Renommer | Renomme la session actuelle
 | Revenir en arrière | Revient à la session actuelle telle qu'elle était lors de sa dernière sauvegarde
 | Mettre comme défaut | Modifie les paramètres par défaut de session
 | Gestionnaire de session | Gère toutes les sessions
 | Filtres de fichier | Inclut ou exclut certains fichiers ou dossiers par nom ou par date
 | Contrôle de comparaison | Critères de comparaison, ajustement du fuseau horaire et d'autres paramètres de session

Voir également
Plus d'Informations sur les Sessions
Partager les Sessions


Vue d'Ensemble des Filtres de Fichiers

Le Visualiseur de Fichier compare deux fichiers texte avec n'importe quel type d'affichage, côte-à-côte ou dessus/dessous. L'affichage utilise des couleurs pour accentuer les différences entre les fichiers. Le Visualiseur de Fichier est conçu pour vous aider à analyser et à apparier les différences. Il y a un certaine variété de fonctions de recherche et d'édition.

Vous pouvez ouvrir de multiples visualiseurs en même temps. Les commandes dans le menu Fenêtre vous aident à gérer de multiples fenêtres.

Veuillez noter :
Le Visualiseur de Fichier est conçu pour traiter uniquement des fichiers texte généraux. Il ne peut pas comparer des documents formatés tels que des fichiers MS Word, Excel ou PDF. Ceux-ci ont des format complexes et propriétaires que le programme ne comprend pas. Utilisez le Visualiseur Hexadécimal ("Hex Viewer") pour comparer des fichiers binaires.

Voir également
Comprendre l'Affichage
Contrôler l'Affichage
Parcourir les Différences
Rechercher du texte
Modifier les Fichiers


Comprendre l'Affichage du Visualiseur de Fichier

Le Visualiseur de Fichier affiche les fichiers dans deux panneaux qui défilent ensemble. Le texte est coloré pour mettre en évidence les différences entre les fichiers. Par défaut, la combinaison des couleurs utilise le rouge pour marquer les différences importantes (insertions, suppressions et modifications) et le bleu pour indiquer les différences non importantes. Les Règles de comparaison de fichiers [image] contrôlent comment le texte est classifié.

Le fond de l'affichage est également coloré pour vous aider à déterminer les différences. Un fond rouge clair indique une différence importante quelque part sur la ligne, tandis qu'un bleu clair indique une différence non importante. Le rouge clair a priorité sur le bleu clair. Cela rend plus facile la recherche des différences, même si elles sont horizontalement en dehors de la vue. (Vous pouvez ajuster ces couleurs pour convenir à vos préférences. Dans le menu Outils, sélectionnez Options, et ensuite Visualiseur de Fichier -> Couleurs.)

Sur le bord gauche de l'affichage se trouve la vue optionnelle en miniature. Elle représente chaque ligne de la comparaison par un ligne de couleur d'un pixel de haut. D'un coup d'oeil, vous pouvez voir les différences d'un bout à l'autre de la comparaison. Le rectangle blanc représente la vue actuelle de l'affichage, et le petit triangle représente la ligne actuelle de l'affichage. Cliquez sur une ligne dans la vue en miniature pour positionner l'affichage à cet endroit.

Dans le base de l'affichage se trouve la zone optionnelle des Détails de Ligne. Elle affiche la ligne actuelle des deux fichiers en utilisant la largeur complète de la fenêtre.


Contrôle de l'Affichage du Visualiseur de Fichiers

Contrôle de l'Affichage du Visualiseur de Fichier

Pour limiter l'affichage, sélectionnez un des filtres d'affichage du menu Voir :

Icône | Légende |
 | Tous | Montre tout le texte
 | Uniquement les Différences | Montre uniquement les lignes avec des différences
 | Différences avec Contexte | Montre les lignes avec des différences, mais inclut également les lignes qui sont avant et après
 | Uniquement les Égalités | Montre uniquement les lignes qui sont identiques

C'est l'affichage par défaut, conçu pour la simplicité.

Basculez vers l'option Ignorer les différences non importantes [image] pour voir ou ignorer les différences non importantes (telles que définies par les Paramètres de règles). Lorsque cette option est enlevée, les différences non importantes apparaîtront avec les différences importantes (par exemple, quand Uniquement les différences [image] est sélectionné). Lorsque cette option est mise, les différences non importantes seront traitées comme du texte identique.

Utilisez Permuter les côtés [image] pour permuter entre elles les zones d'affichage des deux fichiers en cours de comparaison.

Composant

Pour plus de contrôle, vous pouvez configurer la barre d'outils pour afficher les filtres de composant. Pour commuter vers l'affichage des composants, sélectionnez Composant de l'option Barres d'Outils sous le menu Voir. Ces quatre boutons représentent les quatre résultats possibles de comparaison. Vous pouvez activer ou désactiver chacun d'entre eux pour produire des combinaisons non-disponibles avec les filtres composés. Les options Composant sont les suivantes :

Icône | Signification
 | Montrer les paires identiques
 | Montrer les différences
 | Montrer les orphelins de gauche
 | Montrer les orphelins de droite

Options

Les options suivantes sont également disponibles à partir du menu Voir :

Icône | Légende |
 | Disposition Côte-à-Côte | Affiche les deux fichiers en cours de comparaison suivant une orientation côte-à-côte
 | Disposition Dessus-Dessous | Affiche les deux fichiers en cours de comparaison suivant une orientation Dessus-dessous Note: Vous pouvez choisir soit Côte-à-côte, soit Dessus-dessous
 | Montrer les Espaces Blancs | Montre les caractères normalement invisibles tels que les espaces, les tabulations et les fins de ligne
 | Montrer les Numéros de Lignes | Affiche le numéro de ligne de chaque ligne dans son fichier respectif, et ce, dans une zone de fond grise précédant la ligne elle-même
 | Montrer les Miniatures | Affiche une vue colorée côte-à-côte des différences entre les fichiers, à gauche de l'affichage des fichiers
 | Détails des Lignes | Affiche l'une au dessus de l'autre en dessous de l'affichage des fichiers, les lignes correspondant à la sélection
 | Règle | Affiche la règle dans la zone de détail de ligne. C'est seulement adéquat si vous avez une police avec un pas fixe dans votre visualiseur.

Pour certains types de fichiers (*.html, *.xml, *.jpg, *.gif), vous pouvez commuter entre la vue de style Web du fichier. Cliquez sur le boutons Voir comme une page Web [image] à droite du titre du fichier. (Cette possibilité ne fonctionne pas dans les fichiers Zip). Si le fichier est situé dans un site FTP, vous devrez saisir une URL équivalente Web.

Pour améliorer la qualité de la comparaison, éditez les règles de comparaison [image].

Pour changer l'appareillement du texte entre les côtés de gauche et de droite d'une ligne, sélectionnez Aligner manuellement dans le menu contextuel, et ensuite faites de même sur la ligne du côté opposé que vous voulez appareiller. Pour dissocier une ligne ou un groupe de lignes de l'autre côté, cliquez avec le bouton de droite, et sélectionnez Isoler dans le menu contextuel.

Pour changer l'apparence de l'affichage, ouvrez le menu Outils et cliquez sur Options. Dans l'onglet Visualiseur de Fichier -> Couleurs, éditez les paramètres comme vous le souhaitez. Vous pouvez changer la police du visualiseur sur la page Polices.


Parcourir les Différences

Les fonctions Différence suivante [image] et Différence précédente [image] vous aide à balayer pas à pas toutes les différences dans vos fichiers, et toutes les différences de vos fichiers. Dans le Visualiseur de Fichier, cliquer sur Différence suivante pour vous positionner à la section suivante de texte différent, ou sur Différence précédente pour revenir à la différence précédente.

Il y a des options qui vous donne le contrôle complet du fonctionnement. Dans le menu Outils du Visualiseur de Fichier, cliquez sur Options et sélectionnez l'onglet Visualiseur.

Sous Différence suivante, sélectionnez Avancer par section pour parcourir pas à pas les sections de texte non-concordant, et sélectionner Avancer par ligne pour avancer ligne par ligne. Si vous avancez par section, vous pouvez cocher Sélectionner automatiquement la section pour sélectionner la section entière quand vous y entrez. Vous pouvez supprimer ou copier une section entière de différences vers l'autre côté avec une touche clavier supplémentaire.

Sous Plus aucune différence, sélectionnez le comportement préféré lorsqu'il n'y a plus de différence dans le fichier :

  • Ne pas changer la position
  • Revenir à la première différence dans le fichier,
  • Ou, Ouvrir le fichier différent suivant, aller à la première différence

Autoriser l'option Bip pour produire un son en plus du comportement. Les icônes de flèches changent également de couleur, d'un jaune brillant vers un jaune terne pour indiquer que la commande ouvrira le fichier suivant.

Pour sauter directement au fichier suivant avec des différences lorsqu'on est dans le Visualiseur de Fichier, dans le menu Rechercher, sélectionnez Aller au fichier différent suivant, ou Aller au fichier différent précédent.


Pour Rechercher du Texte

Dans le Visualiseur de Fichier, sélectionnez Chercher [image] du menu Rechercher.

Les options du dialogue de Recherche sont :

Option | Signification
Sensible à la casse | Trouve uniquement du texte avec la même casse de caractère (majuscule ou minuscule).
Mots entiers uniquement | Rechercher port ne trouvera pas ports, report or portier.
Recherche avec bouclage | Lorsqu'une fin du fichier est atteinte, continue la recherche depuis l'autre bout.
Expression régulière | Interprète chaque chaîne de caractères comme une expression régulière compatible Perl.
Côté | Sélectionnez Gauche ou Droit pour déterminer de quel côté de la comparaison de fichier rechercher.
Direction | Sélectionnez En avant ou En arrière pour déterminer le sens de la recherche.
Portée | Sélectionnez Globale pour rechercher dans le fichier entier, ou sélectionnez Texte sélectionné pour rechercher uniquement dans le texte sélectionné.
Origine | Sélectionnez soit A partir du curseur ou Portée globale pour déterminer où la recherche démarrera.

Sélectionnez Chercher Suivant [image] or Chercher Précédent [image] pour continuer la recherche du même texte.

Pour chercher et remplacer du texte, sélectionnez Remplacer [image].


Modifier les Fichiers

Le Visualiseur de Fichier peut exécuter des fonctions de base de modification. Ces commandes du menu Editer affectent le côté actuellement sélectionné dans le visualiseur :

Icône | Légende | Signification
 | Copier vers l'autre côté | Copie les lignes sélectionnées vers le côté opposé.
 | Modifier la ligne | Modifie la ligne courante. La modification intervient dans la zone Détail de la Ligne en bas de la fenêtre.
 | Insérer une ligne vide | Insère une ligne blanche. Sélectionnez plusieurs lignes pour insérer plusieurs lignes vides.
 | Augmenter l'indentation | Indente les lignes sélectionnées d'une tabulation.
 | Diminuer l'indentation | Enlève la valeur en espaces blancs d'une tabulation des lignes sélectionnées.
 | Couper | Copie les lignes sélectionnées vers le presse-papier, puis les supprime.
 | Copier | Copie les lignes sélectionnées vers le presse-papier.
 | Copier les deux côtés vers le presse-papier | Étend implicitement la sélection de l'autre côté, et copie les deux côtés vers le presse-papier en séparant chaque couple de lignes avec le caractère de tabulation.
 | Coller | Insère le contenu du presse-papier comme de nouvelles lignes. (Ne remplace pas les lignes sélectionnées.)
 | Supprimer | Supprime les lignes sélectionnées.

Vous pouvez exécuter des opérations composées. Par exemple, vous pouvez copier une ligne d'un côté vers l'autre, et puis la modifier ensuite.

Sélectionnez Défaire [image] pour défaire la commande de modification la plus récente, ou Refaire [image] pour ré-appliquer une commande défaite.

La commande Recharger les fichiers change le texte qui a été modifié par son état original. Elle est différente de Défaire. Utilisez Recharger les fichiers lorsque vous avez effectué plusieurs changements à vos fichiers, et que vous souhaitez enlever les modifications sans affecter les éditions ultérieures. Recharger les fichiers apparaît uniquement dans le menu contextuel en sélectionnant un texte modifié.


Comparer le Contenu du Presse-papier

Pour charger le contenu du presse-papier de Windows dans l'un des côté du Visualiseur de Fichier :

  1. Sélectionnez le côté souhaité.
  2. Dans le menu Fichier, sélectionnez Ouvrir le Presse-papier.

Il remplacera le contenu précédent de ce côté. Pour ajouter le contenu du presse-papier au texte existant, utilisez à la place la commande Coller.


Comparer des fichiers Delphi .DFM

Les fichiers .DFM de Delphi de Borland sont quelquefois stockés comme des fichiers binaires, mais Beyond Compare les convertira automatiquement en fichiers texte pour leur visualisation et modification. Ils seront affichés côte-à-côte de telle façon que vous pourrez identifier les propriétés des formulaires qui ont été changées.

Après avoir modifier un fichier .DFM, Beyond Compare essaiera de le sauver en binaire. Si la conversion en binaire ne fonctionne pas (par exemple par suite d'erreurs de syntaxe), il sera sauvegardé en texte.


Vue d'Ensemble des Modules d'Extension (Plug-ins )

Les modules d'extension étendent les fonctionnalités de Beyond Compare en fournissant des fenêtres alternatives de comparaison de fichiers, des possibilités de balayage, ou de la gestion de contenant. Ils permettent d'étendre les caractéristiques de Beyond Compare sans devoir déclencher la production d'une nouvelle version.

Par exemple, le module d'extension Hex Viewer (Visualiseur Hexadécimal) fournit une vue côte-à-côte de fichiers binaires, où les différences sont en surbrillance.

Le modules d'extension ne fonctionnent qu'avec une copie enregistrée de Beyond Compare. Nous avons un variété de modules d'extension visualiseurs, gratuits pour les utilisateurs enregistrés, et disponibles sur notre site :
www.scootersoftware.com/v2plugins

Voir également
Installer un module d'extension (plug-in)


Installer un Module d'Extension (Plug-in) Visualiseur

Pour installer un module d'extension :

  1. Dé-zippez le fichier téléchargé dans le dossier du programme Beyond Compare (par défaut, C:\Program Files\Beyond Compare 2).
  2. Redémarrez BC et allez dans Outils | Options | Règles. Le module d'extension apparaîtra dans la section "Modules d'extension chargés".
  3. Cliquez sur le bouton Nouvelle afin de créer un nouveau jeu de règles. Dans la section "Sélectionnez le gestionnaire", sélectionnez le module d'extension dans la liste déroulante.
  4. Dans la boîte de dialogue suivante, entrez un nom unique pour le jeu de règles et entrez les extensions de fichiers que vous souhaitez associer au module d'extension. Cliquez sur OK.


Fusionner les Changements de Code source

si vous programmez en C++, VB, Delphi, HTML ou tout autre langage, Beyond Compare peut vous aider à gérer les modifications de votre code source. La comparaison côte-à-côte isole rapidement les fichiers qui ont été changés, et le Visualiseur de Fichier vous permet d'analyser les différences. Vous pouvez facilement fusionner les modification de travaux indépendants sur le code source - peut-être faits par des programmeurs en différents endroits. Il peut être également utilisé pour garder synchrone le code de différentes plateformes.

Exemple 1: Partager votre code

Exemple 2: Transporter les sources


Vérifier les Copies

Vous pouvez utiliser Beyond Compare pour effectuer une comparaison octet par octet de fichiers ou d'arborescences complètes de dossiers.

Exemple
Après avoir gravé un CD, utilisez Beyond Compare pour vérifier l'exactitude de la copie :

  1. Sélectionnez la racine du CD et le dossier du disque dur contenant la copie comme dossiers de base.
  2. Cliquez sur Sélectionner tout [image], et ensuite Comparer les Contenus
  3. Cochez Comparaison binaire et cliquer sur Démarrer

Tous les fichiers de tous les sous-dossiers seront comparés, et un rapport des différences sera affiché.

Un autre exemple
 Utilisez Beyond Compare pour copier des arborescences de dossier entre serveurs. Une fois la commande terminée, utilisez la fonctionnalité de comparaison binaire pour vérifier que la copie est exacte.


Conserver les Dossiers Synchronisés

Beyond Compare est grandiose pour conserver deux dossiers synchronisés l'un avec l'autre.

Exemple 1: Création d'un Raccourci de Synchronisation

Exemple 2: Automatisation de la Synchronisation


Gérer des Sites Web via FTP

Si vous gérez un site Web au travers d'une connexion FTP, Beyond Compare peut vous être d'une grande aide. Il contient un support FTP, qui traitera votre site comme un dossier distant. Vous pouvez utiliser l'Assistant de Comparaison pour créer une session afin de gérer votre site. Sélectionnez Nouvelle [image] dans le menu Session. Choisissez Synchronisation avec un site FTP et suivez les instructions pour créer une nouvelle session.

Exemple 1: Stratégies pour Faire Apparaître les Différences

Exemple 2: Gestion du Site

Exemple 3: Localisation


Reconstruire les Données Endommagées

Lorsque de bonnes données deviennent mauvaises, Beyond Compare peut vous aider à les remettre d'aplomb. Souvent, au long du temps, une erreur pour rendre les choses pire. Beyond Compare vous aide à détecter rapidement ces déviations, et vous fournit des outils pour les réparer soigneusement.

Exemple 1: Restauration Sélective de Fichiers


Observer les Modifications dans le Temps

Si vous utilisez Beyond Compare pour voir ce qui a changé, ou pour être sûr que rien n'a changé dans vos données.

Exemple 1: Comparer à un Instantané

Exemple 2: Conseils pour l'Instantané

Exemple 3: Voir les changements de la Base de Registre


Intégration Shell (menu contextuel de l'explorateur de Windows)

Si vous sélectionnez l'option "Ajouter au menu contextuel (clic du bouton droit)" lors de l'installation de Beyond Compare, le programme installe une Extension Shell afin de s'ajouter lui-même dans le menu contextuel de l'Explorateur Windows. Ensuite, de n'importe quelle fenêtre de l'Explorateur, vous pouvez sélectionner le premier et/ou le second côté de la comparaison. Beyond Compare est exécuté lorsque deux items (dossiers ou fichiers) ont été sélectionnés.

Exemple 1
Comparer le contenu d'une archive zip avec un dossier réel.

1. Dans la fenêtre de l'Explorateur de Windows, cliquez avec le bouton droit sur le fichier zip, et ensuite cliquez avec le bouton gauche sur "Sélectionner le côté gauche à comparer" :

2. Ensuite cliquez avec le bouton droit sur le dossier souhaité, et cliquez avec le bouton gauche "Comparer à XXX" :

En utilisant cette technique, vous pouvez comparer n'importe quel couple de fichiers ou de dossiers. Les fichiers Zip et les fichiers instantanés (.bcss) sont traités comme des dossiers.

Exemple 2
Comparer deux fichiers en utilisant un visualiseur autre que celui par défaut.

Dans l'Explorateur Windows, sélectionnez deux fichiers image, cliquez sur eux avec le bouton droit et choisissez "Hex Viewer" du menu "Comparer en utilisant" :


Glisser et Déposer

Vous pouvez utiliser la facilité Windows de "glisser et déposer" ("drag and drop") avec Beyond Compare pour comparer les fichiers et les dossiers. Glisser un couple de fichiers ou de dossiers à partir d'un programme tel que l'Explorateur de Windows, et déposer-les dans Beyond Compare pour la comparaison.

Si Beyond Compare ne s'exécute pas déjà, glisser les items sur l'icône de Beyond Compare. Si Beyond Compare est en cours d'exécution, vous pouvez déposer un dossier dans le panneau de gauche ou de droite de la fenêtre du Visualiseur de Dossier pour y ouvrir le dossier. Ou déposer un couple de dossiers n'importe où dans la fenêtre principale pour y ouvrir les deux.

Pour les fichiers texte, déposez-en un dans le panneau de gauche ou de droite de la fenêtre du Visualiseur de Fichier, ou déposer un couple de fichier n'importe où dans la fenêtre. Si vous déposez plus de deux fichiers ou dossiers, seulement les deux premiers seront reconnus.

Si Beyond Compare s'exécute mais est minimisé ou est en arrière-plan, vous pouvez glisser les items sur le bouton de Beyond Compare dans la barre des tâches, attendre un moment (sans relâcher), et la fenêtre de Beyond Compare sera affichée pour vous en avant-plan.


Paramètres de la Ligne de Commande

Vous pouvez exécuter Beyond Compare avec des paramètres de ligne de commande pour accélérer l'accès à vos dossiers ou fichiers favoris. Vous pouvez spécifier :

  • un nom de session
  • deux noms de dossier
  • deux noms de fichier, ou
  • un fichier script.

Si vous spécifiez un nom de session existante, cette session sera chargée lors du démarrage de Beyond Compare. Par exemple :
BC2.EXE "Mon Application <-> Disquette"

Vous pouvez spécifier deux dossiers sur la ligne de commande :
BC2.EXE C:\ALPHA C:\BETA
Note : Si vous spécifier deux dossiers sur la ligne de commande, les paramètres par défaut de la session seront utilisés.

Vous pouvez également spécifier deux fichiers sur la ligne de commande, et Beyond Compare les comparera directement dans le Visualiseur de Fichier, en sautant la fenêtre du Visualiseur de Dossier :
BC2.EXE POMMES.TXT ORANGES.TXT

Pour automatiser la synchronisation de dossiers et d'autres tâches, vous pouvez référencer un fichier script sur la ligne de commande :
BC2.EXE @SCRIPT.TXT

De plus, vous pouvez contrôler Beyond Compare en utilisant les indicateurs de la ligne de commande.

Voir aussi
Traitement des scripts


Indicateurs de la Ligne de Commande

Indicateur

Signification

/expandall

Étend tous les dossiers lors du chargement de la première session.

/fileviewer, /fv

Démarre dans le mode Visualiseur de Fichier.

/fileviewer=xxx, /fv=xxx

Démarre avec le module d'extension (plug-in) xxx
(eg. /fv="Hex Viewer").

/filters=xxx

Positionne le filtre initial de nom de fichier à xxx.
(eg. /filters=*.*)

/noedit

Interdit la modification des fichiers dans le Visualiseur de Fichier.

/out=xxx

Déprécié. Produit un rapport de Comparaison de Dossiers ou de Différences de Fichiers avec le format xxx de la version 1. Fonctionne également avec les indicateurs /expandall et /rules.

/quickcompare, /qc

Exécute une comparaison rapide basée sur des règles, et positionne le niveau d'erreur DOS. Les niveaux d'erreur sont :

  • 0 = égal
  • 1 = similiaire
  • 2 = différent
  • 3 = erreur

/quickcompare=xxx, /qc=xxx

Exécute une comparaison rapide de type xxx, où xxx est size, crc, binary, ou rules-based.

/readonly
/leftreadonly
/rightreadonly

Interdit toute opération qui pourrait affecter un coté particulier ou les deux côtés (en mode Visualiseur de Fichier ou Visualiseur de Dossier).

/rules=xxx

Lors de l'ouverture du Visualiseur de Fichier, utilise la règle xxx
(eg. /rules="Tout le reste").

/savetarget=xxx

La commande "Sauver" du Visualiseur de Fichier écrira par dessus le fichier spécifié au lieu du fichier original.
C'est également supporté comme /mergeoutput=xxx.

/silent

Supprime la fenêtre de script et l'item de la barre de tâche.

/title1=xxx
/title2=xxx

Définit le titre pour le fichier1 ou le fichier2 comme étant xxx (en mode Visualiseur de Fichier). Le titre remplace le texte du chemin d'accès lorsqu'on ne le modifie pas.


Vue d'Ensemble des Scripts

Utilisez un Script pour vous servir de Beyond Compare à partir d'une ligne de commande. Un script est un texte simple qui contient une liste de commandes qui peuvent contrôler le programme et exécuter automatiquement des opérations sur des fichiers.

Les scripts s'exécutent sans afficher la fenêtre habituelle du Visualiseur de Dossier, mais peuvent demander des saisies pour certaines confirmations. Pour exécuter un script, spécifiez-le sur la ligne de commande en le préfixant avec le symbole '@' tel que dans :

     BC2.exe @C:\BC2\MonScript.txt

Dans son utilisation de base, un script est une simple série de commandes. Le plus petit script sensé devrait être quelque chose comme :

     load "C:\Windows\Temp"
     select all
     delete all

qui supprime tous les fichiers et les dossiers du répertoire "Temp" de Windows.

Les scripts manipulent essentiellement une comparaison invisible de dossiers : les opérations de fichiers demandent des sélections, l'"affichage" peut être limité avec des filtres, et les dossiers peuvent être étendus pour les parcourir récursivement.

Les scripts sont traités ligne par ligne, avec un commande unique par ligne. La casse, les lignes blanches et les commentaires (n'importe quoi après un "#") sont ignorés. Les arguments sont séparés par des espaces; pour inclure un espace dans un argument, entourez l'argument avec des guillemets ("). Pour continuer une langue commande sur une seconde (ou troisième) ligne, ajouter une esperluette (&) à la fin de chaque ligne sauf pour la dernière.

En plus des commandes standard, les paramètres de la ligne de commande et les variables d'environnement peuvent être insérées dans le script au moment où il s'exécute. Les variables de la ligne de commande sont spécifiées par le signe pourcent (%) suivi d'un nombre unique de 1 à 9. Le nom du script et les commutateurs de la ligne de commande commençant par / ne sont pas inclus dans la liste 1-9. La commande de script :

     load "%1"

chargera n'importe quelle session fournie sur la ligne de commande, telle que dans "BC2 @script.txt MaSession".

Les variables d'environnement sont insérées en entourant leur nom entre des signes Pourcent, et sont sensibles à la casse. Ce qui suit exécute la même chose que le script précédent, excepté qu'il prend le répertoire de l'environnement :

     load "%TMP%"
     select all
     delete all

Il y a également plusieurs variables dynamiques que Beyond Compare peut remplir à chaque ligne de script. La variable %date% correspond à la date courante au format aaaa-mm-jj. Le format de la variable %time% dépend des paramètres régionaux de votre ordinateur. La variable %fn_time% sort le temps en hh-mm-ss, ce qui peut être utile pour les noms de fichier.

Voir également
Référence du langage de Script
Exemple de Scripts


Référence du language de script

Référence du langage de Script

Voici les commandes de script (par ordre alphabétique) :

ATTRIB BEEP COLLAPSE COMPARE COPY COPYTO CRITERIA DELETE EXPAND FILE-REPORT FILTER FOLDER-REPORT LOAD LOG MOVE OPTION RENAME REPORT SELECT SNAPSHOT SYNC TOUCH

ATTRIB (Attribut)

Utilisation :
attrib (+|-)<ensemble d'attribut 1> [(+|-)<ensemble d'attribut 2> <...>]

Met (+) ou enlève (-) l'ensemble d'attribut des items de la sélection courante. Un ensemble d'attributs peut inclure comme attribut archive (a), système (s), caché (h), et lecture seule (r).

Exemples :
attrib +h
attrib +sh -a

BEEP (bip)

Utilisation :
beep

Bippe le haut-parleur du PC.

COLLAPSE (Compresse)

Utilisation :
collapse all
collapse <chemin d'accès> [<chemin d'accès> [...]]

Ferme tous les dossiers ou les dossiers des chemins d'accès spécifiés. Les chemins d'accès sont relatifs au dossier de base et ne peuvent pas contenir de caractères génériques.

Exemple :
collapse "Dossier 1" Dossier2\SousDossier

COMPARE (Compare)

Utilisation :
compare [CRC|binary|rules-based]

Compare les contenus de la sélection courante en utilisant le type de comparaison. Par défaut, le type de comparaison le plus récent est utilisé

Cette commande ne fait que comparer les fichiers une seule fois. Pour changer comment les fichiers sont comparés après modification, utilisez criteria.

COPY (Copie)

Utilisation :
copy (lt->rt|rt->lt)

Copie les fichiers/dossiers sélectionnés dans la direction indiquée (lt = Gauche, rt = Droite).

COPYTO (Copie vers)

Utilisation :
copyto (lt|rt|all) [path:(relative|base|none)] <chemin d'accès>

Copie les fichiers/dossiers sélectionnés du côté spécifié vers le chemin spécifié en utilisant les options de chemin. Par défaut, path:none est utilisé.

CRITERIA (Critères)

Utilisation :
criteria [attrib:<ensemble d'attributs>] [version] \
         [timestamp[:[#sec][;IgnoreDST]]] \
         [size|CRC|binary|rules-based] \
         [timezone:(ignore|(lt|rt)(+|-)<0..12>)]

Positionne tous les paramètres des critères de comparaison.

  • attrib autorise les comparaisons de l'ensemble des attributs spécifiés.
  • version autorise les comparaisons d'information de version des EXEs et DLLs.
  • timestamp autorise les comparaisons de date/heure.
    • #sec considère les différences dans une tolérance de secondes comme égalités.
    • IgnoreDST (ignore heure d'été/hiver) considère des différences de 1 heure exactement comme des égalités.
  • size (taille), CRC (CRC), binary (binaire), et rules-based (basée sur des règles) sont les valeurs possibles pour comparer des contenus.
  • timezone ignore les différences de fuseau horaire ou applique le décalage horaire au côté spécifié.
Exemple :
criteria attrib:sh timestamp:2sec;IgnoreDST rules-based timezone:lt+6

DELETE (Supprime)

Utilisation :
delete [recyclebin=(yes|no)] (lt|rt|all)

Supprime les fichiers/dossiers actuellement sélectionnés des côtés spécifiés;
recyclebin=yes : Déplace dans la corbeille, =no : Détruit;
lt = gauche, rt = droite, all = des deux côtés.

EXPAND (Étend)

Utilisation :
expand all
expand <chemin d'accès> [<chemin d'accès> [...]]

Ouvre tous les dossiers ou les dossiers des chemins d'accès spécifiés. Les chemins d'accès sont relatifs au dossier de base et ne peuvent pas contenir de caractères génériques. Les dossiers doivent être ouverts de telle façon que leur contenu puissent être utilisé avec d'autres commandes telles que select.

FILE-REPORT (Rapport de Fichier)

Utilisation :
file-report layout:<disposition> [options:<options>] \
            [title:<titre du rapport>] \
            output-to:(printer|clipboard|<nom de fichier>) \
            [output-options:<options>] [<nom de fichier 1> <nom de fichier 2>]

Génère un rapport de comparaison de fichier pour les fichiers sélectionnés actuellement.

  • layout contrôle l'apparence des rapports, et peut être choisi parmi over-under (dessus-dessous), side-by-side (côte-à-côte), composite, patch (correctif), statistics ou xml.
  • options est optionnel et est utilisé différemment pour chaque disposition .
    • ignore-unimportant (ignore non important) traite les différences dans du texte non important comme des égalités et est disponible dans toutes les dispositions.
    • display-all (affiche tout), display-mismatches (affiche les inégalités), display-context (affiche le contexte) ou display-matches (affiche les égalités) peuvent être utilisés pour contrôler quelles lignes de la comparaison sont inclues dans le rapport, et sont disponibles dans toutes les dispositions excepté patch et statistics. Par défaut, display-all est utilisé.
    • line-numbers inclut les numéros de lignes dans la disposition side-by-side.
    • les formats stats-descriptive ou stats-tabular (CSV) sont disponibles sans la disposition statistics. Par défaut, stats-descriptive est utilisé.
    • les formats patch-standard, patch-context, patch-unified ou patch-classic sont disponibles sans la disposition patch. Par défaut, patch-standard est utilisé.

Aussi bien file-report que folder-report doivent inclure une information vers où envoyer le rapport, et peuvent inclure une information additionnelle sur le format de sortie.

  • title contrôle le titre qui apparaît en tête du rapport.
  • output-to contrôle la destination de la sortie. Ce peut être printer (imprimante), clipboard (presse-papier) ou un nom de fichier.
  • output-options est optionnel et est utilisé différemment pour chaque destination de sortie.
    • les types de couleur print-color ou print-mono sont disponibles pour une sortie printer.
    • les orientations print-portrait ou print-landscape sont disponibles pour une sortie printer. Par défaut, print-portrait est utilisé.
    • les renvois automatiques en fin de ligne
    • wrap-none, wrap-character ou wrap-word contrôlent si les longues lignes sont renvoyées à la ligne suivante. Printer la sortie peut utiliser chacunes des trois options. HTML la sortie peut utiliser wrap-none et wrap-word. Par défaut, wrap-none est utilisée.
    • les feuilles de style html-color, html-mono ou html-custom=<nom de fichier> sont disponibles pour des sorties clipboard et file. Si html-custom est utilisée, elle doit inclure une URL ou un chemin d'accès qui sera utilisé comme feuille de style externe.
Exemples :
file-report layout:over-under options:display-context output-to:printer &
            output-options:print-color,wrap-word
file-report layout:patch options:ignore-all,patch-unified &
            output-to:"rapports\rapport.txt"

FILTER (Filtre)

Utilisation :
filter <masques de fichier>
filter cutoff:([<|>](<date heure>|#[days])|none)
filter attrib:((+|-)<ensemble d'attributs>|none)
filter size:([<|>]#[KB|MB|GB]|none)

Contrôle quels dossiers et quels type de fichiers seront comparés en utilisant le filtrage par nom (masques de fichier), le filtrage par date (cutoff) ou les autres filtrages (attrib ou size).

  • Les Filtres par Nom incluent et excluent les fichiers et dossiers basés sur leur noms et chemins d'accès. Des masques multiples peuvent être séparés par des points-virgules. Pour indiquer qu'un masque est un masque d'exclusion, utilisez un moins (-) en tête du masque. Pour indiquer qu'un masque affecte les dossiers, utilisez une barre oblique reversée (\) à la fin.
  • cutoff exclut tous les fichiers plus anciens (<) ou plus récents (>) qu'une date/heure ou qu'un nombre de jours à partir de la date système actuelle (#days). Par défaut, cutoff:< est utilisé. none peut être utilisé pour enlever un filtrage par date. L'analyse des dates est plutôt indulgente, mais si vous voulez être sûr qu'elle s'effectue correctement, utilisez le format spécifié par les paramètres régionaux du système d'exploitation. (Voir Panneau de Configuration -> Options Régionales et Linguistiques.) L'heure est optionnelle et doit suivre la date (cutoff:"01/01/2001 12:00pm"). Rappelez-vous d'utiliser les guillemets (" ") lorsqu'un terme contient un espace.
  • attrib limite la comparaison aux fichiers qui ont l'attribut (+), et aux fichiers qui n'ont pas l'attribut (-). none peut être utilisé pour enlever un filtrage par attribut.
  • size exclut tous les fichiers plus petits (<) ou plus grands (>) que la taille donnée. Par défaut, la taille est donnée en octets, mais vous pouvez ajouter KB, MB ou GB à la fin pour indiquer que la valeur est en kilooctets, mégaoctets ou gigaoctets respectivement. none peut être utilisé pour enlever le filtre sur la taille.
Exemples :
filter "*.pas;*.dpr;*.dfm"
filter cutoff:<7days
filter cutoff:>"Jan 1, 2001"
filter cutoff:"01/01/2001 12:00pm"
filter attrib:-sh
filter "*.txt;-Corbeille\" attrib:+r

FOLDER-REPORT

Utilisation :
folder-report layout:<disposition> [options:<options>] \
              [title:<titre du rapport>] \
              output-to:(printer|clipboard|<nom de fichier>) \
              [output-options:<options>]

Génère un rapport de comparaison de dossier pour les dossiers de base actuellement chargés. Les dossiers sont montrés dans leur état courant. Pour inclure les sous-dossiers, ajoutez une commande expand all ceci.

  • layout contrôle l'apparence des rapports, et peut être side-by-side (côte-à-côte), summary (résumé), or xml.
  • options est optionnel.
    • Les indicateurs de filtre d'Affichage contrôles quels fichiers sont inclus dans le rapport. Les valeurs possibles sont : display-all (affiche tout), display-mismatches (affiche les inégalités), display-no-orphans (affiche les non orphelins), display-mismatches-no-orphans (affiche les inégalités non orphelines), display-orphans (affiche les orphelins), display-left-newer (affiche les plus récents à gauche), display-right-newer (affiche les plus récents à droite), display-left-newer-orphans (affiche les plus récents orphelins à gauche), display-right-newer-orphans (affiche les plus récents orphelins à droite) et display-matches (affiche les égalités). Par défaut, display-all est utilisé.
    • Des colonnes optionnelles peuvent être incluses dans le rapport en utilisant les indicateurs column-version, column-size (taille), column-crc, column-timestamp (date/heure), et column-attributes. Par défaut, column-size et column-timestamp sont incluses. column-none (aucune) peut être utilisé seul pour ne pas mettre les colonnes par défaut.
  • Les arguments title (titre), output-to (sortie vers) et output-options (options de sortie) sont documentés sous file-report.
Exemples :
folder-report layout:side-by-side,column-size,column-version,column-timestamp &
              output-to:clipboard output-options:html-color
folder-report layout:xml output-to:"C:\Rapport de Dossier.xml"

LOAD (Charge)

Utilisation :
load <session>
load <chemin d'accès de gauche> [<chemin d'accès de droite>]
load <default>

Charge la session spécifiée, les dossiers de base spécifiés ou les Paramètres de la Session par Défaut (load <default>). L'impossibilité de charger un dossier de base provoquera l'arrêt du script.

  • Charger une session provoque l'utilisation de tous les paramètres de cette session, excepté le filtre d'affichage.
  • Charger des dossiers de base utilise les paramètres actuellement actif. Par défaut, les paramètres par défaut du programme sont utilisés.
Exemples :
load MaSession
load c:\projet x:\projet

LOG (Journalise)

Utilisation :
log [none|normal|verbose] [[append:]<nom de fichier>]

Contrôle le niveau de détail du journal et où il est stocké.

  • none (aucun), normal et verbose (verbeux) détermine la profondeur des détails utilisés dans le journal. La journalisation est initialement arrêtée et démarre lorsque le mode est changé de none.
  • append: provoque une journalisation ajoutée au fichier au lieu de le remplacer. Par défaut, le journal est sorti comme Log.txt dans le répertoire système courant.

MOVE (Déplace)

Utilisation :
move (lt->rt|rt->lt)

Déplace les fichiers/dossiers sélectionnés actuelle dans la direction spécifiée (lt = gauche, rt = droite).

OPTION (Option)

Utilisation :
option stop-on-error
option confirm:(prompt|yes-to-all|no-to-all)

Ajuste les options de traitement du script.

  • stop-on-error (stopper en cas d'erreur) fait en sorte que lorsque le script attend diverses conditions d'erreur, incluant les erreurs d'opérations sur des fichiers, et lorsqu'une erreur survient, il demande à l'utilisateur avant de continuer.
  • confirm (Confirmer) peut utiliser prompt (Demander), yes-to-all (Oui à tout) ou no-to-all (Non à tout) pour traiter les dialogues de confirmation qui arrivent suite aux opérations de fichiers. Par défaut, prompt est utilisé.

RENAME (Renomme)

Utilisation :
rename [regexpr <ancien masque>] <nouveau masque>

Réalise un renommage multi-fichier pour la sélection actuelle en utilisant le nouveau masque spécifié. regexpr utilise un ancien masque pour effectuer un "Renommage via Expression Régulière". Par défaut, un "Renommage DOS" est effectué.

REPORT (désapprouvé)

Cette commande a été désapprouvée et ne sera pas mise-à-jour pour supporter de nouvelle possibilité de rapport. Utilisez FILE-REPORT ou FOLDER-REPORT à la place.

Utilisation :
report format:<format> \
       output:(<printer>|<clipboard>|<nom de fichier>)[;<options>] \
       [<nom de fichier 1> [<nom de fichier 2>]]

Produit un rapport de Comparaison de Dossiers ou un rapport de Différences de Fichier au format donné et l'envoie vers la destination spécifiée. Les rapports de Comparaison de Dossiers utiliseront toujours les dossiers de base actuellement chargés. Les rapport de Différences de Fichiers se rapporteront aux fichiers donnés, autrement, ce sera un rapport pour tous les fichiers sélectionnés.

Les différents codes de format sont listés ici.

Le rapport peut être dirigé vers l'imprimante par défaut, le presse-papier ou vers un fichier spécifique. <printer> (imprimante) et <clipboard> (presse-papier) sont des mots-clés qui incluent les '<' et '>'.

Les options pour output:<printer> sont :
p mode portrait (défaut)
l mode paysage
c sortie colorée

Pour output:<clipboard> (sortie vers le presse-papier) ou output:<nom de fichier>, utilisez l'option h pour spécifier une sortie HTML.

Exemples :
load "C:\SiteWeb" "ftp://monsiteweb.com/"
report format:50n output:Rapport.html;h
report format:03d output:<printer> C:\Exemple\Fichier1.txt C:\Exemple\Fichier2.txt

SELECT (Sélectionne)

Utilisation :
select <masque de sélection 1> [<masque de sélection 2> <...>]

Sélectionne les contrôles sur lesquels les fichiers et les dossiers peuvent opérer. Uniquement les fichiers et les dossiers qui correspondent au moins à un des masques de sélection font partie de la sélection. Un masque de sélection est au format [<côté>.][<différence>.]<item>.

  • Un côté (gauche : left ou lt, droit : right ou rt, les deux : all) limite la sélection au côté spécifié. Par défaut, all est utilisé.
  • Une différence (exacte : exact, différence : diff, plus récente : newer, plus ancienne : older, orphelin : orphan, tous : all) limite la sélection basée sur le résultat de la comparaison. diff correspond aux différences pour les critères autres que les dates/heures. Utilisez newer ou older à la place. Les dossiers doivent contenir uniquement le type de résultat spécifié à affecter. Par défaut, all est utilisé.
  • Un item (fichiers : files, dossiers : folders, tout : all) limite la sélection aux fichiers, dossiers ou les deux.

empty.folders (dossiers vides) est un masque de sélection spécial qui sélectionne les dossiers vides.

Exemples :
select lt.files rt.orphan.folders
select all

SNAPSHOT (Photographie)

Utilisation :
snapshot [save-crc][save-version][expand-archives][no-filters] \
         lt|rt|path:<chemin d'accès> [output:<cible>]

Sauvegarde un cliché en lecture seule du répertoire spécifié.

  • save-crc calcule le CRC de tous les fichiers et les stocke comme partie de l'instantané.
  • save-version stocke l"information de versions pour les fichiers exécutables.
  • expand-archives stocke le contenu des fichiers archives dans un format étendu.
  • no-filters stocke tous les fichiers sans tenir compte des filtres actifs de nom de fichiers.
  • lt (gauche), rt (droite) et path (chemin) indique quel dossier est stocké. lt et rt sauvera l'instantané d'un des dossiers de base chargé, et path sauvera un instantané du chemin d'accès spécifié.
  • output est optionnel et détermine où l'instantané sera sauvé. Par défaut, il sera sauvé dans le répertoire courant.
    • Si la cible est un nom de fichier qualifié entièrement, ce sera le nom de l'instantané. Si la cible n'a pas d'extension, .bcss sera utilisée.
    • Si la cible n'est pas incluse ou se réfère à un dossier, un nom de fichier sera généré, basé sur le nom du dossier source et sur la date système courante, eg dossier_2000-12-31.bcss. Si nécessaire, un numéro additionnel sera ajouté au nom généré afin d'éviter l'écrasement d'instantanés existants.
Exemples :
snapshot save-crc save-version no-filters path:C:\ output:D:\
snapshot lt output:"Copie Maison.bcss"

SYNC (Synchronise)

Utilisation :
sync [visible][create-empty] (update|mirror):(lt->rt|rt->lt|all)

Utilise le moteur de Synchronisation de Dossiers pour mettre à jour un couple de dossiers. Cette commande n'utilise pas la sélection courante.

  • visible autorise le comportement "Affecte uniquement les fichiers visibles". Uniquement les fichiers des dossiers développés seront affectés.
  • create-empty autorise le comportement "Crée les dossiers vides".
  • update (met à jour) copie les fichiers plus récents et orphelins dans la direction indiquée, en laissant les orphelins et les nouveaux fichiers de l'autre côté inchangés. Utiliser all pour la direction indique une synchronisation bidirectionnelle, et copies les fichiers plus récents et orphelins dans les deux directions.
  • mirror (miroir) rend le dossier cible identique à la source. Les fichiers plus récents, plus anciens, différents ou orphelins sont tous copiés vers la destination, et les orphelins dans la destination sont supprimés. Utiliser all comme direction ne s'applique pas dans ce contexte et n'est pas valide.
Exemple :
sync create-empty mirror:lt->rt

TOUCH (Touche, Modifie la date/heure)

Utilisation :
touch (lt->rt|rt->lt)
touch (lt|rt|all):(now|<date heure>)

Copie les dates/heures des fichiers d'un côté vers l'autre, ou positionne les dates/heures de tous les fichiers du côté spécifié à la date et à l'heure système courante (now) ou à la date/heure spécifiée. Vous devez sélectionner des fichiers avant de pouvoir modifier leur date/heure.


Exemple de Scripts

Voici un script de base qui copie tous les nouveaux fichiers ainsi que les orphelins d'un dossier vers un autre, en utilisant une session créée auparavant :

  load "Sync Portable"
  expand all
  select left.newer.files left.orphan.files
  copy left->right

Voici un script avancé qui synchronise deux dossiers spécifiques en utilisant des filtres avancés. Cela fonctionne dès le chargement des dossiers dans le Visualiseur de Dossier, et en exécutant une synchronisation de dossier "Miroir de Gauche à Droite"

  # Met la journalisation en marche
  log normal "C:\Mes Documents\PageWeb\Synclog.txt"
  # Charge la session par défaut et exclut tout sauf certains types de fichiers
  load <default>
  filter "*.html;*.htm;*.png;*.jpg"
  # Charge les dossiers de base
  load "C:\Mes Documents\PageWeb" "ftp://utilisateur@ftp.un-fai.com/racineweb"
  expand all
  # Copie les plus récents, différents et orphelins de gauche vers un site FTP
  select lt.newer.files lt.diff.files lt.orphan
  copy lt->rt
  # Supprime tous les fichiers orphelins du site FTP
  select rt.orphan
  delete rt


Où Beyond Compare Mémorise-t-il ses Paramètres

Beyond Compare conserve ses données dans la Base de Registre et également dans le dossier des Données Applicatives défini par Windows.

Base de Registre
Toutes les options générales de programme de Beyond Compare, la localisation des barres d'outils, etc., peuvent être trouvées dans la Base de Registre sous la clé :
HKEY_CURRENT_USER\Software\Scooter Software\Beyond Compare

Dossier des Données Applicatives
Le dossier des Données Applicatives est défini par utilisateur, et sa localisation dépend de votre version de Windows. Par exemple, sous Windows 2000/XP, ça peut être :
C:\Documents and Settings\<nom d'utilisateur>\Application Data

Beyond Compare crée un sous-dossier "Scooter Software\Beyond Compare" où sont stockés vos sessions et règles dans deux fichiers : Sessions.bcse et Rules.bcru.

Mode Répertoire Unique
Vous pouvez forcer Beyond Compare à stocker tous vos paramètres dans le même dossier que le programme (par défaut, "C:\Program Files\Beyond Compare 2") en créant un fichier vide nommé BC2.ini dans le dossier du programme. Vous pouvez copier manuellement les fichiers de règles et de sessions vers le dossier du programme.


Déplacer BC vers un autre ordinateur

Pour copier ou déplacer Beyond Compare vers un ordinateur différent, nous vous recommandons de ré-exécuter le programme d'installation, et de ressaisir votre clé d'enregistrement.

Si vous avez BC 2.1 sur l'ancien ordinateur :

  1. Exécuter BC 2.1 sur l'ancien ordinateur et choisissez Exporter les réglages dans le menu Outils pour sauvegarder les paramètres souhaités dans un fichier.
  2. Copier ces paramètres sur le nouvel ordinateur.
  3. Exécuter BC 2.1 sur le nouvel ordinateur et choisissez Importer les réglages du menu Outils pour charger le fichier des paramètres.

Si vous avez BC 2.0 sur l'ancien ordinateur :

Pour conserver les définitions et les règles de votre session, copiez les fichiers Session.bcse et Rules.bcru. Ceux-ci sont localisés dans votre dossier de Données Applicatives (voir Où Beyond Compare Mémorise-t-il ses Paramètres).


FAQ, Questions Fréquemment Posées (Frequently Asked Questions)

Comment puis-je comparer des fichiers ayant des noms différents ?
Puis-je comparer des documents Microsoft Word ou Excel avec Beyond Compare ?
Je sais que ces fichiers-ci sont identiques, pourquoi BC dit-il qu'ils sont différents ?
Comment faire en sorte que BC utilise mes paramètres favoris pour de nouvelles sessions ?
Pourquoi mes fichiers sont-ils différents après les avoir placés sur mon site ?
Pourquoi ne puis-je pas ouvrir xyz.cab ou xyz.exe comme une archive ?
Comment faire pour intégrer Beyond Compare dans le système de contrôle de version xxx ?

Comment puis-je comparer des fichiers ayant des noms différents ?
Cliquez avec le bouton droit sur le premier fichier et sélectionnez "Comparer à..." dans le menu contextuel. Ensuite, cliquez sur le second fichier. Ils peuvent être du même côté ou de deux côtés différents de la comparaison de dossier.

Ou bien, dans l'Explorateur Windows, cliquez avec le bouton droit sur le premier fichier et choisissez "Sélectionner le côté gauche à comparer". Cliquez avec le bouton droit sur le deuxième fichier et choisissez "Comparer à...".

Retour en haut

Puis-je comparer des documents Microsoft Word ou Excel avec Beyond Compare ?
Beyond Compare ne peut pas traiter en natif les fichiers Word ou Excel, et affichera des bizarreries si vous essayer d'ouvrir un fichier .doc ou un .xls dans le Visualiseur de Fichier. Toutefois, Beyond Compare 2.1 peut utiliser automatiquement Word pour convertir des fichiers .doc vers des fichiers texte temporaires avant la comparaison. Le résultat n'inclura pas les informations sur les polices de caractère, les entêtes de page, etc., donc nous ne supportons pas l'édition de la comparaison résultante. Pour un exemple d'utilisation de Word à partir de Beyond Compare, téléchargez l'ensemble des règles MS Word à partir de www.scootersoftware.com/morerules.

Retour en haut

Je sais que ces fichiers-ci sont identiques, pourquoi BC dit-il qu'ils sont différents ?
C'est probablement parce qu'ils ont des différences de caractères de fin de ligne, ainsi, effectuer une comparaison binaire indiquera une différence même si le texte courant est le même. Par exemple, Windows place des caractères de contrôle CR et LF à la fin de chaque ligne, alors qu'UNIX utilise LF seul. Des fichiers qui ont été copiés ou modifiés sur des systèmes différents peuvent contenir différents styles. (Le module d'extension Visualiseur Hexa est pratique pour identifier exactement ce qui est différents dans ce cas.) Si vous sélectionnez l'option "Comparaison Basée sur des Règles" (dans le Contrôle de comparaison), alors les comparaisons de contenu utiliseront les mêmes règles que le Visualiseur de Fichier.

Retour en haut

Comment faire en sorte que BC utilise mes paramètres favoris pour de nouvelles sessions ?
Lorsque vous avez paramétré BC comme vous le souhaitez, choisissez "Mettre comme défaut" dans le menu "Sessions". Ensuite cliquez sur "Positionner les réglages actuels comme défaut".

Retour en haut

Pourquoi mes fichiers sont-ils différents après les avoir placés sur mon site ?
Il y a deux raisons principales qui peuvent expliquer pourquoi les fichiers seront différents immédiatement après leur téléchargement vers le site.

(1) Les fichiers un une taille modifiée.
Les fichiers texte (HTML, code source,etc.) peuvent être stockés dans des formats radicalement différents sur les sites FTP, et ceci peut amener à une augmentation ou une diminution des tailles de fichier par un petit pourcentage. Le Visualiseur de Fichier de Beyond Compare et la comparaison basée sur des règles traitent tous les deux ces différences, mais une comparaison de la taille uniquement ne le peut pas. Beyond Compare ne peut pas détecter cela directement, ainsi pour faire en sorte que les fichiers apparaissent comme égaux, vous avez besoin d'utiliser une comparaison basée sur des règles et enlever les comparaisons de taille et qui se basent sur les dates de fichiers.

(2) Il n'a pas été possible de positionner la date du fichier.
Tous les sites FTP ne supportent pas le changement de date des fichiers téléchargés. Lorsque cela arrive, la date du fichier sera en fait le moment où vous l'avez téléchargé. Dans beaucoup de cas, vous pouvez contourner ce point en cochant l'option "Modifier la date/heure des fichiers locaux lors de la copie vers un site FTP" dans le dialogue "Contrôle de comparaison". Après avoir téléchargé le fichier, Beyond Compare copiera la date à partir du site FTP et mettra à jour le fichier local, ainsi les fichiers seront assortis la prochaine fois que vous les comparerez.

Retour en haut

Pourquoi ne puis-je pas ouvrir xyz.cab ou xyz.exe comme une archive ?
Il y a plusieurs types incompatibles de fichiers dont l'extension est .CAB. Beyond Compare supporte uniquement le format Cabinet Microsoft, et ne pourra pas ouvrir les autres types.

Un problème apparenté concerne les CAB auto-extractibles. Ils sont similaires aux fichiers ZIP auto-extractibles, et peuvent être ouverts dans WinZip. Beyond Compare ne peut actuellement pas comprendre ces fichiers et refusera de les ouvrir.

Retour en haut

Comment faire pour intégrer Beyond Compare dans le système de contrôle de version xxx ?
Vous pouvez paramétrer la plupart des systèmes de contrôle de version pour appeler Beyond Compare afin de comparer des fichiers. Nous avons des informations pour en paramétrer certains sur www.scootersoftware.com/vcs.

Retour en haut


Remonter les Problèmes

si vous avez découvert un problème avec Beyond Compare, nous souhaiterions que vous nous en parliez !

Dans la fenêtre principale du Visualiseur de Dossier, sélectionnez Support dans le menu Aide, et suivez les instructions pour produire un état de votre programme et des paramètres du Système. Coller cet état dans un email à nous adresser, et incluez-y une description du problème.

Vous souhaiteriez nous envoyer une copie d'écran qui illustre le problème. Pour le faire, suivez les étapes suivantes pour faire un courrier électronique (email) assez petit :

  1. Pressez ALT+Impr. écran pour placer un cliché de la fenêtre actuelle dans le presse-papier.
  2. Ouvrez le programme Paint de Microsoft (Démarrer -> Programmes -> Accessoires -> Paint) et pressez Ctrl+V pour y coller l'image.
  3. Sélectionnez la partie de l'image que vous voulez envoyer.
  4. Cliquez sur Copier vers du menu Édition, changez Type soit en Bitmap 16 couleurs, soit en Bitmap 256 couleurs, et saisissez un nom de fichier.
  5. Si possible, utilisez un utilitaire de zip pour compresser le fichier image.
  6. Joignez le fichier image à l'email que vous nous destinez.


Comment Nous Contacter

Les utilisateurs enregistrés sont autorisés à nous demander du support par courrier électronique (email). Nous sommes également heureux de supporter les utilisateurs non enregistrés tant qu'ils évaluent le logiciel.

Envoyez tout commentaire, suggestion ou bogue (bug) à :
support@scootersoftware.com

Si vous souhaitez obtenir de l'aide pour commander Beyond Compare, contactez :
sales@scootersoftware.com

Notre adresse postale est :
Scooter Software
2828 Marshall Court, #208
Madison, WI 53705-2276
USA

Pour la dernière version de Beyond Compare et pour d'autres nouvelles concernant le programme, visitez notre site Web à :
www.scootersoftware.com


Contrat de Licence

Vous devez lire soigneusement les termes et les conditions avant d'utiliser Beyond Compare. Sauf si vous avez un contrat de licence différent signé par Scooter Software, l'utilisation de ce logiciel indique votre accord avec ce contrat de licence et la garantie. Si vous n'acceptez pas ces termes, vous devez cesser immédiatement d'utiliser ce logiciel.

Protection, Copyright
Beyond Compare ("le Logiciel") est protégé (c) 1996-2004 par Scooter Software Inc., Tous droits réservés.

Évaluation et Enregistrement
Ce n'est pas un logiciel gratuit. Vous êtes autorisé à utiliser le Logiciel dans un but d'évaluation sans coût pour une période de 30 jours. Si vous utilisez le Logiciel après la période d'évaluation de 30 jours, un coût d'enregistrement est requis, comme décrit dans la documentation. L'utilisation non enregistrée du Logiciel après la période d'évaluation de 30 jours est une violation des lois de Copyright américaines et internationales.

Une seule copie enregistrée du Logiciel peut être soit utilisée par une personne unique qui utilise personnellement un ou plusieurs ordinateurs, soit installée sur un seul ordinateur utilisé par plusieurs personnes, mais non les deux.

Une organisation peut acheter une licence de site multi-utilisateur dont le coût autorise soit les individus qui ont accès à n'importe quel ordinateur de l'organisation, soit un nombre d'ordinateurs auxquels accèdent n'importe quel nombre d'utilisateurs de ce Logiciel. Un site est défini comme l'ensemble des établissements de la société dans un cercle de rayon égal à 100 miles (161 kilomètres). Les licences de site n'incluent pas les filiales, ni les clients de cette société.

Distribution
Tant que vous n'incluez pas votre Clé d'Enregistrement, vous êtes autorisé à copier le Logiciel, donner des copies exactes de l'original à n'importe qui, et à distribuer le Logiciel dans une forme non modifiée via des moyens électroniques. Il vous est spécifiquement interdit de faire payer pour de telles copies.

Loi Gouvernementale
Cette licence est contrôlée par les lois de l'état du Wisconsin, USA.

Dédit de Garantie
CE LOGICIEL ET LES FICHIERS L'ACCOMPAGNANT SONT VENDUS "EN L'ÉTAT" ET SANS GARANTIE DE GAINS DE PERFORMANCE OU TOUTE AUTRE GARANTIE EXPRIMÉE OU DÉDUITE. AUCUNE GARANTIE DE REMPLIR UN BESOIN PARTICULIER N'EST OFFERTE. LA RESPONSABILITÉ DU VENDEUR EST UNIQUEMENT DE REMBOURSER LE PRIX D'ACHAT.


Licence Indy

Beyond Compare utilise Internet Direct (Indy) pour ses fonctionnalités FTP. Les instructions suivantes sont fournies de la part des auteurs de Indy :

Copyright
 Des parties de ce logiciel sont protégées Copyright (c) 1993 - 2004, Chad Z. Hower (Kudzu) et l'équipe Indy Pit Crew - http://www.IndyProject.org/

Licence
 La distribution et l'utilisation dans des sources ou sous forme binaire, avec ou sans modification, sont autorisées si toutefois les conditions suivantes sont remplies :

  • Les distributions du code source doivent conserver la notice de protection ci-dessus, la liste des conditions et l'avertissement suivant.
  • Les distributions sous forme binaire doivent reproduire la notice de protection ci-dessus, la liste des conditions et l'avertissement suivant dans la documentation, la boîte de dialogue "A propos" et/ou tout autre matériel fourni avec la distribution.
  • Aucun nom de personne ni d'organisation associé au projet Indy ne peut être utilisé pour soutenir, avaliser ou promouvoir des produits dérivés de ce logiciel sans l'autorisation préalable et écrite de la personne ou de l'organisation concernée.

CE LOGICIEL EST FOURNI "TEL QUEL" PAR Chad Z. Hower (Kudzu) et l'équipe Indy Pit Crew ET TOUTES GARANTIES EXPRESSES OU INDUITES, INCLUANT, MAIS NON LIMITÉE À, LES GARANTIES INDUITES DE COMMERCIABILITÉ ET D'INTÉGRATION POUR UN BUT PARTICULIER SONT DÉSAVOUÉES. EN AUCUN CAS, LES RÉGENTS OU CONTRIBUTEURS NE SERONT RESPONSABLES DE DOMMAGE DIRECT, INDIRECT, INCIDENTAL, SPÉCIAL, EXEMPLATIF, OU CONSÉQUENT (INCLUANT MAIS NON LIMITÉ À, L'OBTENTION DE BIENS OU DE SERVICES DE SUBSTITUTION; PERTE D'UTILISATION, DE DONNÉE OU DE PROFIT, OU D'INTERRUPTION D'AFFAIRES) POURTANT CAUSÉS ET EN THÉORIE RESPONSABLES, SI PAR CONTRAT, LA RESPONSABILITÉ OU LE TORT (INCLUANT LA NÉGLIGENCE OU AUTREMENT) ARRIVANT DE N'IMPORTE QUELLE FAÇON PAR L'UTILISATION DE CE LOGICIEL MÊME EN ÉTANT AVERTI DE LA POSSIBILITÉ D'UN TEL DOMMAGE.

THIS SOFTWARE IS PROVIDED BY Chad Z. Hower (Kudzu) and the Indy Pit Crew "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


Comment Commander Beyond Compare

Le prix de Beyond Compare pour un utilisateur unique est de US$30. Nous avons des prix réduits pour les licences multi-utilisateurs.

Pour des instructions sur la commande de licence, visitez notre boutique en-ligne à :

http://www.scootersoftware.com/buynow


Automatiser la Synchronisation

Vous pouvez utiliser le processeur de script de Beyond Compare pour accomplir certaines tâches, telles que la synchronisation de dossiers sans aucune interaction. Par exemple, pour automatiser une sauvegarde de votre dossier C:\Mes Documents, entrez les commandes de script suivantes dans le Bloc-notes :

  load "C:\Mes Documents" "C:\Sauvegardes"
  expand all
  select left.newer.files left.orphan.files
  copy left->right

Sauvez ce fichier texte en : C:\Mes Documents\Sync.txt

Un script Beyond Compare peut être exécuté n'importe quand en utilisant le Planificateur de Tâches de Windows :

  1. Ouvrez le Panneau de Configuration et double-cliquez sur Tâches planifiées.
  2. Double-cliquez sur Création d'une tâche planifiée.
  3. Dans l'assistant de Tâches planifiées, sélectionnez "Beyond Compare 2" à partir de la liste des applications installées et suivez les instructions.
  4. Double-cliquez sur la tâche nouvellement créée pour ouvrir la boîte de dialogue Propriétés.
  5. Dans le champ Exécuter, ajouter une référence à votre fichier script :
    <chemin d'accès>BC2.exe @Sync.txt
  6. Dans le champ Commencer dans, mettez l'endroit où se trouve le fichier script :
    "C:\Mes Documents"

Nous recommandons d'inclure une commande log dans votre script. Si vous rencontrez des difficultés avec votre script, consultez le journal des erreurs de Tâches Planifiées : "SchedLgU.txt" dans votre répertoire Windows.


Changer les Attributs

Dans le menu Actions, la commande Attributs modifie les attributs Lecture seule, Caché ou Archive des fichiers ou dossiers sélectionnés. Vous ne pouvez pas changer l'attribut Système.

Si un dossier est sélectionné, ses attributs sont modifiés mais pas son contenu. Pour modifier les attributs du contenu d'un dossier, vous devez étendre ce dossier et sélectionner tout son contenu.

Les cases à cocher montrent l'état actuel des items sélectionnés. Si une case n'est pas cochée, alors cet attribut n'est pas mis pour tous les fichiers sélectionnés. Si une case est cochée, cet attribut est mis pour tout ce qui est sélectionné. Une boîte grisée indique que certains fichiers ont l'attribut, et que d'autres ne l'ont pas.

Décochez une case pour enlever l'attribut de tous les fichiers sélectionnés, ou cochez-la pour positionner l'attribut.


Comparer les Contenus

A partir du menu Actions, Comparer les contenus [image] compare les contenus des fichiers et dossiers sélectionnés, et affiche le résultat quand c'est terminé.

Si un dossier est sélectionné, son contenu, incluant ses sous-dossiers, sont comparés en respectant les filtres de fichiers, mais sans prendre en compte les effets de filtre d'affichage. Toutefois, si un dossier ouvert est sélectionné et que n'importe lequel de ses enfants également, alors la sélection du dossier est ignorée et seuls les enfants sélectionnés seront comparés.

Légende | Signification
Comparaison binaire | Tous les octets des fichiers sont comparés
Comparaison CRC | Les valeurs des CRC des fichiers sont comparées
Comparaison basée sur des règles | Les règles définies par l'utilisateur sont utilisées pour déterminer les différences importantes et non importantes

Lorsque c'est terminé, une fenêtre de Résultats de Comparaison apparaît, fenêtre qui contient la vue arborescente des résultats. Ouvrez chaque groupe pour voir les fichiers spécifiques. Cela peut être un groupe libellé [image] Dossiers et Fichiers Filtrés qui listera les fichiers non comparés à cause des filtres effectifs. Vous pouvez double-cliquer sur n'importe quel fichier listé pour l'examiner dans le visualiseur associé.

Après la comparaison du contenu, la colonne centrale du Visualiseur de Dossier sera mise à jour pour refléter les résultats (pour autant que les fichiers comparés apparaissent de part et d'autre).

Noter que des items peuvent disparaître du Visualiseur de Dossiers lors de la comparaison. Par exemple, supposons qu'un couple de fichiers aie des dates différentes, mais qu'en fait ils soient identiques. Initialement, avant que leurs contenus ne soient comparés, ils apparaîtront comme distincts dans le Visualiseur de Dossier. Si vous avez mis le filtre Uniquement les différences [image] et exécuté une comparaison de contenu pour ces deux fichiers, ils disparaîtront de l'affichage dès que Beyond Compare déterminera qu'ils sont en fait identiques.

Quand l'option Ignorer les différences importantes [image] n'est pas positionnée, des textes similaires seront traités comme des différences. Quand cette option est mise, des fichiers similaires seront traités comme égaux. Cela rend facile l'aperçu de différences importantes dans de grandes arborescences de dossiers en n'ayant pas les différences non importantes dans le chemin.


Comparaison des Fichiers dans le Visualiseur

Comparer des Fichiers dans le Visualiseur

Si un seul fichier est sélectionné, Beyond Compare le chargera dans le visualiseur associé, et s'il y en a un qui existe, le fichier en face également. Si deux fichiers sont sélectionnés, ils sont chargés ensemble dans le Visualiseur de Fichier, en ignorant les fichiers qui sont en face l'un de l'autre.

Pour comparer des fichiers ayant un nom différent, tenez la touche CTRL enfoncée, et sélectionnez Comparer dans le visualiseur.

Le Visualiseur de Fichier incorporé a été pensé pour prendre en compte les fichiers texte uniquement. Il ne peut pas comparer directement les documents formatés tels que les fichiers MS Word, Excel ou PDF. Ils ont des formats complexes et propriétaires que le programme ne peut pas comprendre. Toutefois, vous pouvez configurer les Règles de Comparaison de Fichier pour appeler un outil externe de conversion afin d'extraire le texte lui-même du document avant la comparaison. Voyez notre site Web pour les règles des modules d'extensions (add-ons) que vous pouvez télécharger :
www.scootersoftware.com/morerules


Comparer avec un Instantané

Beyond Compare peut sauvegarder l'état actuel d'un dossier dans un fichier spécial Instantané. Cet Instantané contient la liste du dossier et de ses sous-dossiers. Optionnellement, il peut inclure la somme de contrôle CRC32 de chaque fichier -- une bonne façon de détecter des changements dans le contenu de fichier sans prendre beaucoup de place dans le fichier instantané.

A un moment ultérieur, Beyond Compare peut comparer le fichier Instantané avec le contenu actuel d'un dossier, et montrer quels sont les changements depuis que l'Instantané a été créé.

Pour créer un Instantané :

  1. Sélectionnez Sauver l'Instantané [image] dans le menu Actions.
  2. Choisissez le Côté Gauche et le Côté Droit, ou entrez un chemin spécifique.
  3. Autorisez Enregistrer les CRC (pour un Instantané plus complet)

L'Instantané est un fichier dont l'extension est .bcss, stocké par défaut dans votre dossier "Mes Documents". Lorsque vous avez besoin de comparer l'Instantané par rapport à vos données actuelles, double-cliquez simplement sur le fichier Instantané, et il sera ouvert dans Beyond Compare avec le dossier actuel dont il est issu.


Configuration des Applications "Ouvrir avec"

Pour configurer des applications additionnelles qui apparaîtront dans le sous-menu Ouvrir avec, cliquez sur Options dans le menu Outils, et sélectionnez la page Ouvrir avec. Cliquer Nouvelle pour ajouter ou Modifier pour modifier une application. Cliquez sur Avancé pour faire apparaître des options supplémentaires.

Entrez un nom dans le champ Description qui apparaîtra dans le menu Ouvrir avec.

Entrez une Ligne de Commande correcte pour lancer l'application. Elle peut inclure des indicateurs de ligne de commande appropriés à cette application. Les variables suivantes seront remplacées par les informations indiquées :

%f chemin et nom du fichier

%l (L minuscule) numéro de ligne actuelle dans le Visualiseur de Fichier

%n Uniquement le nom du fichier

%p Le chemin absolu

%x L'extension (qui inclut '.')

%b Le nom de base (Nom du fichier sans l'Extension)

%F Le nom et le chemin relatif au répertoire de travail

%P Le chemin relatif au répertoire de travail

'1' et '2' peuvent être ajoutés à la fin des variables pour indiquer le fichier gauche en premier, ou le fichier droit en second (eg. "BC2 %F2 %F1"). Dans tous les cas, excepté pour le deuxième %f ou %l (pour des raisons de compatibilité précédentes), omettre un nombre réfère au premier fichier sans prendre en compte le nombre de fois qu'il apparaît dans la ligne de commande.

Le champ Répertoire de travail vous permet d'indiquer où le programme s'exécutera. S'il est vide, le programme s'exécutera dans le même répertoire que BC2. Il peut être positionné à un répertoire spécifique, ou à une des valeurs spéciales <Dossier parent> et <Répertoire de base> dans la liste déroulante. <Dossier parent> indique le répertoire parent du fichier sélectionné et <Répertoire de base> indique le répertoire de base du côté sélectionné (ou le dossier parent uniquement en mode Visualiseur de Fichier).

Utilisez le champ Délimiteur de chemin pour remplacer tous les délimiteurs de chemin avec le texte indiqué. La valeur par défaut est le barre reversée (\).

L'option Accepte contrôle quand l'application sera disponible pour les fichiers, les dossiers ou les deux. Conseils : Vous pouvez configurer Beyond Compare lui-même comme une application additionnelle pour les dossiers. De cette façon, vous pourrez sélectionner des dossiers et les comparer dans une autre instance de Beyond Compare.

Rafraîchir quand c'est fini exécute un Rafraîchissement Rapide lorsque BC a terminé avec la liste Ouvrir avec.

Lorsque l'option Instances multiples est cochée, vous pouvez sélectionner de multiples fichiers ou des couples de fichiers, et exécuter l'opération sur chacun d'entre eux, ou par couple de fichiers alignés. Avec cette option, BC teste si un second fichier est indiqué sur la ligne de commande (eg. "%x2"). Si c'est le cas, l'application sera exécutée chaque fois avec chaque couple, autrement, il séparera le couple et s'exécutera pour chaque fichier sélectionné dans le couple.

Attendre qu'une instance se termine indique à BC d'attendre que le programme précédent se termine avant de lancer la commande suivante.


Configurer les Barres d'Outils

Dans Beyond Compare, les barres d'outils sont facilement configurables suivant votre goût. Vous pouvez glissez la poignée de gauche de chaque barre d'outils pour la repositionner, ou la détacher comme une barre flottante.

Dans le menu Voir, cliquez sur Barres d'Outils et cochez ou décochez le nom des différentes barres d'outils pour afficher ou cacher les barres d'outils correspondantes. Notez que la barre d'outils Filtres d'affichage dans le Visualiseur de Dossier est représentée avec trois différents styles : Liste déroulante, Composé ou Composant.

Pour paramétrer plus loin les barres d'outils, dans le menu Voir, cliquez sur Barres d'Outils puis sur Paramétrer. Dans la boîte de dialogue Paramétrer les Barres d'Outils, sélectionnez une barre d'outils dans la liste. Cochez la case près de chacun des boutons que vous voulez voir affichés, ou décochez ceux que vous voulez voir cachés. Pour afficher les légendes avec les icônes sur les barres d'outils, autorisez l'option Grands boutons avec texte.

Pour verrouiller la position de vos barres d'outils, arrangez-les d'abord comme vous le souhaitez, puis dans le dialogue Paramétrer les Barres d'Outils, commutez l'option Position de la Barre d'Outils de Déplaçable vers Verrouillée.


Copie de Fichiers, Dossiers

Dans le menu Actions, la commande Copier [image] copie les fichiers et dossiers sélectionnés d'un côté vers l'autre du Visualiseur de Dossier, écrasant les fichiers existant du côté cible.

Si un dossier est sélectionné, tout son contenu sera copié sans prendre en compte les filtres de fichiers, ni les filtres d'affichage activés. Toutefois, si un dossier ouvert est sélectionné et qu'un de ses enfants l'est aussi, alors la sélection de dossier est ignorée et seuls les enfants sélectionnés seront copiés.

Par défaut, une boîte de confirmation apparaît avant la copie. Pour sauter la confirmation, ouvrez le menu Outils, cliquez sur Options, allez à l'onglet Confirmations, et décochez l'option Confirmer la copie.


Copie vers un Dossier

Dans le menu Actions, la commande Copier vers un dossier [image] copie les fichiers et dossiers sélectionnés vers un certain dossier, optionnellement avec un chemin d'accès intact. Vous pouvez sélectionner des items dans un côté ou l'autre du Visualiseur de Dossier, mais pas dans les deux.

Si un dossier est sélectionné, tout son contenu sera copié sans prendre en compte les filtres de fichiers, ni les filtres d'affichage activés. Toutefois, si un dossier ouvert est sélectionné et qu'un de ses enfants l'est aussi, alors la sélection de dossier est ignorée et seuls les enfants sélectionnés seront copiés.

Exemple d'Options de Chemin d'accès
 Dans cet exemple, trois items sont sélectionnés : Le fichier 10.txt, le dossier Q et le fichier 30.txt.

L'image ci-dessous montre comment seront les items dans le dossier cible, en utilisant chacune des options de chemin d'accès.

Conserver la structure relative du répertoire Détermine la différence minimale entre tous les chemins d'accès des fichiers sélectionnés, et crée cette structure dans le dossier cible. Dans cet exemple, les dossiers D et P n'ont pas été sélectionnés mais ils ont été créés dans le dossier cible afin de conserver une structure relative identique.

Conserver la structure relative du dossier de base Crée le chemin complet (par rapport au répertoire de base) dans le dossier cible.

Ne pas conserver la structure du répertoire parent Ignore toutes les informations de chemin d'accès, et copie ensemble tous les fichiers et dossiers sélectionnés vers le répertoire cible. Dans cet exemple, uniquement le dossier Q a été créé dans le répertoire cible parce qu'il n'a pas été spécifiquement sélectionné.


Créer un Raccourci de Synchronisation

Si vous synchronisez souvent un couple de dossiers, vous pouvez créer un raccourci pour accélérer le traitement :

  1. Créez une session nommée avec les deux noms de dossiers, si vous le souhaitez, spécifiez les filtres de fichiers, et positionnez le filtre d'affichage à Uniquement les différences [image]. Sauvegardez la session et quittez Beyond Compare.
  2. Créez un nouveau raccourci vers Beyond Compare sur votre Bureau.
  3. Cliquez avec le bouton droit sur le raccourci, sélectionnez Propriétés, et allez dans l'onglet Raccourci.
  4. Dans le champ Cible, ajouter le nom de votre session entre guillemets à la fin de la ligne. Par exemple :
    "C:\Program Files\Beyond Compare 2\BC2.exe" "Correspondance Journalière"

Pour synchroniser les dossiers, double-cliquez sur ce nouveau raccourci et utilisez la commande Synchroniser vers la droite [image] ou Synchroniser vers la gauche [image].


Créer un Nouveau Dossier

La commande Nouveau Dossier du menu Actions vous permet de créer un dossier à la position actuelle. Si vous avez un fichier ou un dossier sélectionné, le nouveau dossier sera créé sous le même dossier parent que l'item sélectionné.

Si les deux côtés sont sélectionnés, un nouveau dossier sera créé des deux côtés.

Pour créer un nouveau dossier et l'utiliser comme dossier de base, entrez le chemin d'accès du nouveau dossier dans la zone de saisie de gauche ou de droite, et tapez ENTRÉE. Dans la fenêtre d'avertissement qui apparaît, cliquez Créer.


Détails des Critères

Pour voir ou changer les critères de comparaison d'une session, sélectionnez Contrôle de comparaison [image] dans le menu Session. Ou, aller dans l'onglet Critères du Gestionnaire de Sessions [image] .

Dates/Heures

Critère | Effet
Tolérance, en secondes | Les dates/heures doivent différer d'autant de secondes pour être considérées comme différentes. C'est utile pour le Système de Fichiers FAT qui arrondit les heures sur un multiple de 2 secondes.
Ignore la différence d'heure d'été/hiver | Ignore les différences de temps qui sont un multiple exact d'heures. C'est utile lorsque le changement d'heure produit un décalage d'heures pour certains et pas pour d'autres.

Si le critère de date/heure est activé, la date/heure de dernière modification est considérée comme l'évidence d'une différence. Vous pouvez positionner cette option pour ignorer les petites différences d'heures (dues à différentes façons de stocker ces dates/heures), ou des heures entières (suite au changement d'heure d'été/hiver).

Vous pouvez souhaiter de ne pas tenir compte du critère Date/Heure lorsque ces dates/heures ne représentent pas le fait que le fichier aie été modifié. Par exemple, copier un fichier vers un site FTP ne conserve pas la date/heure du fichier, ainsi vous pouvez vouloir empêcher le critère Date/Heure et vous baser sur le critère Contenu.

Contenus

Critère | Effet
Taille uniquement | Compare les tailles de fichier.
Taille et CRC | Compare les tailles de fichier et les CRC calculés à partir du contenu
Comparaison binaire | Compare le contenu des fichiers octet par octet
Comparaison basée sur des Règles | Compare le contenu des fichiers en se basant sur les règles associées

La taille d'un fichier est la méthode la plus brute (mais la plus rapide) pour mesurer le contenu d'un fichier. Si les tailles ne sont pas égales, alors il est certain que les fichiers diffèrent.

Le CRC se réfère au Test de Redondance Cyclique ("Cyclical Redundancy Check"), un calcul mathématique effectué à partir du contenu d'un fichier. Dans le cas où le CRC est connu (fichiers zip et Instantané), il donne un bonne approximation pour une comparaison octet par octet.

Une comparaison binaire donne la plus grande assurance que les deux fichiers sont identiques. Cette comparaison peut être plus rapide que de calculer un CRC à partir de rien puisque la comparaison binaire s'arrêtera dès qu'un octets différent sera rencontré.

Une comparaison basée sur des règles est idéale quand vous souhaitez vouloir ignorer certaines différences non importantes. L'importance ou la non-importance d'un texte est définie par les règles de comparaison de fichiers associées au type de fichier. Un couple de fichiers avec des contenus similaires est identifié par une icône spéciale, et peut être traité comme des différences ou des égalités dépendant de l'état de l'option Ignorer les différences non importantes [image].

Versions

Compare les informations de version typiquement stockées dans les fichiers d'application dont l'extension est .exe, .dll, .ocx, etc.

Attributs des Fichiers

Critère | Effet
Archive | Compare les attributs Archive
Système | Compare les attributs Système
Caché | Compare les attributs Caché
Lecture seule | Compare les attributs Lecture seule


Le Problème du Changement d'Heure (Heure d'Eté/Hiver)

Lorsque vous comparez des fichiers provenant de Système de Fichiers différents, pour pouvez noter que les heures diffèrent d'exactement une heure, particulièrement au début et à la fin de la période d'été ("Daylight Savings Time", DST).

Sous NTFS (et quelques autres systèmes de fichiers), les dates/heures de fichiers sont stockées comme heure de fichier, et convertis en Heure Locale Système via une formule basée sur le fuseau horaire, que l'heure d'été soit effective ou non. Deux fois par an, quand l'heure d'été entre en vigueur ou en sort, la formule change - mais la même formule est utilisée avant et après le changement d'heure. Ainsi, si avant le changement d'heure vous prenez note de l'heure d'un fichier sur le serveur et que vous la regardez ensuite aujourd'hui, vous verrez que l'heure apparaît comme ayant sauté d'une heure en avant ou en arrière.

Le système FAT utilisé par Windows 95/98 fonctionne de la manière opposée. Les dates/heures sont stockées telles qu'elles, et ne sont pas affectées par le fuseau horaire ni le changement d'heure. (Quand un programme demande la date/heure d'un fichier, Windows simule le résultat en inversant la formule ci-dessus). Ainsi, la date/heure ne "saute" pas lors du passage à l'heure d'été/hiver.

Si tous vos fichiers sont basés sur les Systèmes de Fichier FAT, ou bien si tous le sont sur NTFS, vous ne remarquerez probablement jamais ça. Mais quand un PC sous Windows 95/98 est relié à un serveur NT et que vous déplacez/comparez des fichiers entre eux, c'est un réel problème.

Pour ignorer les différences d'heures dues à ce problème, ouvrir le menu Session, cliquez Contrôle de comparaison [image], et dans l'onglet Général, cochez l'option Ignorer la différence d'heure d'été/hiver.


Paramètres de Session par Défaut

Lorsque Beyond Compare démarre une nouvelle session, il initialise tous les paramètres avec un jeu particulier de valeurs, appelé session par défaut. La session par défaut est identique aux autres sessions, excepté qu'elle ne contient aucun dossier de base. La session par défaut est utilisée comme un modèle pour les nouvelles sessions vides, et lors du chargement d'un couple de dossiers à partir de la ligne de commande ou de l'extension Shell (menu contextuel de l'explorateur Windows).

Au début, lorsque vous installez Beyond Compare, les paramètres de votre session par défaut seront les défauts du programme. Les valeurs de ces paramètres, valeurs que nous avons décidé de choisir, sont relativement typiques, et sont donc intégrées au programme. Vous pouvez changer la session par défaut pour mieux convenir à vos besoins.

Pour changer la session par défaut, sélectionnez Nouvelle Session Vide [image] du menu Session, ou cliquez Nouvelle [image] dans le dialogue du Gestionnaire de Session. Configurer tous les paramètres comme vous les souhaitez. Ensuite, sélectionnez Mettre comme défaut dans le menu Session et cliquez Positionner les réglages actuels comme défaut. Cela aura pour conséquence que tous les paramètres de la session actuelle (à l'exclusion des dossiers de base) seront sauvés comme la nouvelle session par défaut, écrasant les défauts du programme. Pour les remettre comme avant, cliquez sur le boutons Revenir aux paramètres par défaut du programme.


Définir les Filtres par Défaut

Vous pouvez modifier la liste des filtres prédéfinis dans la liste déroulante Filtres sur la barre d'outils.

  1. Dans le menu Outils, cliquez sur Options.
  2. Dans la page Visualiseur de Dossier, recherchez le champ Filtres par défaut et modifiez-le au besoin.

Utilisez des définitions avec un seul joker, séparées par des points-virgules. Pour inclure une description, soyez sûr de mettre les filtres entre parenthèses. Exemple :

Source HTML (*.htm;*.html;*.xml;*.jpg;*.gif)


Supprimer des Fichiers, Dossiers

Dans le menu Actions, la commande Supprimer [image] supprime les fichiers et dossiers sélectionnés d'un ou des deux côtés de la comparaison.

Si un dossier est sélectionné, son contenu entier sera supprimé sans tenir compte des filtres de fichiers ou des filtres d'affichage actuels. Si un dossier ouvert est sélectionné et également ses enfants, alors la sélection du dossier est ignorée et c'est uniquement ses enfants sélectionnés qui seront supprimés.

Autoriser l'option Utiliser la corbeille si possible pour déplacer les fichiers et dossiers stockés sur un disque local vers la Corbeille au lieu de les détruire complètement. Cette option est ignorée pour les suppressions sur des disques réseau, pour les sites FTP et à l'intérieur des fichiers zip.


Rapport de Comparaison des Dossiers

Pour sortir la comparaison du dossier actuel, sélectionnez Rapport de comparaison des dossiers [image] du menu Actions.

Les options de Disposition du Rapport sont les suivantes :

Disposition du Rapport | Signification
Côte-à-côte | Affiche les dossier côte-à-côte exactement comme le Visualiseur de Dossier le fait.
Résumé | Affiche un résumé de la comparaison de dossier
Dump XML | Exporte la comparaison comme un fichier XML

Vous pouvez sortir n'importe quel des ces rapports vers les endroits suivants :

  • Imprimante
  • Rapport HTML (fichier ou presse-papier)
  • Texte ordinaire (fichier ou presse-papier)

La sortie HTML et vers l'imprimante supporte la mise en surbrillance en couleur des différences.

Vous pouvez prévisualiser la sortie imprimante avec la commande Prévisualiser l'impression, ou un rapport HTML avec la commande Visualiser dans le navigateur.

Par défaut, le rapport se limitera au filtre d'affichage actuel. Forcez-le en sélectionnant un filtre différent dans la liste déroulante. Vous pouvez également marquer les colonnes que vous souhaitéez inclure dans le rapport.


Comment Utiliser les Filtres d'Affichage

Les filtres d'affichage limitent la vue à certains résultats de comparaison. Par exemple, vous pouvez choisir Différences Uniquement [image] pour enlever les fichiers égaux et ainsi vous concentrer sur les différences. Qu'on le veuille ou non, une comparaison est contrôlée par les Critères de comparaison.

Les filtres d'affichage sont des combinaisons des six résultats suivants de comparaison :

Résultat | Lorsque... | Couleurs
Exact | tous les critères concordent |
Différent | contenu différent ou critère d'attribut |
Gauche Uniquement | orphelin du côté gauche |
Droite Uniquement | orphelin du côté droit |
Gauche Plus Récent | la date/heure de gauche est plus récente que celle de droite |
Droite Plus Récent | la date/heure de droite est plus récente que celle de gauche |

Un orphelin est un fichier ou un dossier qui existe d'un côté et pas de l'autre.

Vous pouvez configurer la barre d'outils pour prendre une des trois différente collection de filtres d'affichage :

Composé

Les filtres d'affichage composé sont une combinaison commode des filtres d'affichage Composant. Notez que les icônes représentent les combinaisons de couleurs de la table ci-dessus. Par exemple, le filtre d'affichage Différences mais non orphelins [image] est une combinaison de Gauche Plus Récent + Droite Plus Récent + Différent. Pour une description de chaque icône, sélectionnez Afficher les filtres dans le menu Voir.

Composant

Pour un contrôle ultime, vous pouvez configurer la barre d'outils pour les filtres Composant. Ces six boutons représentent les six résultats possibles de comparaison. Vous pouvez autoriser ou interdire chacun d'entre eux pour produire des combinaisons non disponibles avec les filtres Composé.

Liste déroulante

C'est le style par défaut pour la barre d'outils, structurée pour la simplicité. Ces boutons représentent Tous [image], Uniquement les différences [image] et Uniquement les égalités [image]. La liste déroulante du bouton du milieu vous permet de sélectionnez des variations des résultats de différences.

Voir également
Comment utiliser les filtres de fichiers


Autoriser/Interdire le Balayage Automatique
  1. Dans le menu Session du Visualiseur de Dossier, cliquez sur Contrôle de comparaison [image].
  2. Dans l'onglet Général, sous Gestion de Dossier, cochez ou décochez Balayage automatique des sous-dossiers en arrière-plan.


Exclure des fichiers

Exclure des Fichiers, Dossiers

La commande Exclure du menu Actions exclut les fichiers et dossiers sélectionnés de la session actuelle. Une alternative plus commode est d'ouvrir le dialogue Filtres de Fichiers et d'entrer les exclusions de fichiers/dossiers.

Si vous sélectionnez un ou plusieurs fichiers du même type, la commande Exclure offrira la possibilité d'exclure tous les fichiers de ce type.


Rapport des Différences entre Fichiers

Pour sortir la comparaison de fichier courante, vous avez le choix entre les deux possibilités suivantes :

  • Dans le Visualiseur de Dossier, mettez en surbrillance le fichiers que vous voulez comparer et sélectionnez Rapport des différences entre fichiers [image] du menu Action.
  • Dans le Visualiseur de Fichier, sélectionnez Rapport des différences entre fichiers [image] du menu Fichier.

Dans le Visualiseur de Dossier vous pouvez sélectionner plusieurs fichiers et produire tous les rapports en une seule fois. Autorisez l'option Saut de page entre les rapports dans le dialogue Mise en page si vous voulez que chaque rapport de différence entre fichiers démarre sur une nouvelle page.

Les options de dispositions de Rapport sont les suivantes :

Disposition du Rapportt | Signification
Dessus/dessous | Affiche les lignes avec le côté gauche au-dessus, et le droit en dessous.
Côte-à-côte | Affiche les ligne côte-à-côte exactement comme le Visualiseur de Fichier le fait
Composé | Imbrique les lignes des deux côtés, en mettant celles de gauche au dessus, et celles de droite en dessous.
Correctif | Crée un correctif avec un format générique ou avec un format de la commande diff d'Unix : normal, unifié ou contextuel.
Statistiques | Liste les statistiques de la comparaison sous forme descriptive ou séparée par des virgules.
Dump XML | Exporte la comparaison vers un fichier XML

Note : Beyond Compare ne peut pas traiter la sortie Correctif. Vous devez utiliser un utilitaire externe pour appliquer un correctif à un fichier.

Vous pouvez sortir n'importe quel des ces rapports vers les endroits suivants :

  • Imprimante
  • Rapport HTML (fichier ou presse-papier)
  • Texte ordinaire (fichier ou presse-papier)

Vous pouvez prévisualiser la sortie imprimante avec la commande Prévisualiser l'impression, ou un rapport HTML avec la commande Visualiser dans le navigateur.

Vous pouvez limiter le rapport aux lignes sélectionnées en cochant Uniquement la sélection. Vous pouvez traiter le différences non importantes comme des égalités en cochant Ignorer les diff. non importantes. Si la disposition du rapport est affecté par un filtre d'affichage, ce sera par défaut le filtre courant d'affichage, mais vous pouvez le changer.


Comment Utiliser les Filtres de Fichiers

Avec les Filtres de Fichiers, vous spécifiez le type de fichiers que vous souhaitez inclure dans (ou exclure de) la comparaison. Par exemple, si vous comparez des projets Delphi, vous pouvez inclure des types de fichiers tels que *.pas, *.dfm, et *.dpr. Ou bien, vous pouvez inclure tous les fichiers exceptés *.dcu et *.~* en excluant ces types de fichiers.

Pour spécifier un filtre simple "inclure ces types", utilisez le champ Filtres de la barre d'outils. Entrez les types de fichiers séparés par des points-virgules, ou utilisez la liste déroulante pour sélectionner des types prédéfinis. Incluez un signe "moins" (-) au début des fichiers que vous voulez exclure.

En plus de ces filtres simples de caractères génériques, vous pouvez spécifier des filtres complexes qui incluent ou excluent les fichiers ou les dossiers par nom.

Les fichiers peuvent également être filtrés en prenant comme base leur attributs de date/heure, taille ou fichier. Les dossiers peuvent uniquement être filtrés en prenant comme base leurs noms, mais sont affectés par le filtrage de leurs contenus.

Sur le menu Voir, la commande Supprimer les filtres [image] vous permet de supprimer temporairement les Filtres de Fichiers et les Filtres d'Affichage. Les Fichiers et les Dossiers qui étaient cachés apparaîtront colorés en bleu-gris.

Voir également
Comment Utiliser les filtres d'Affichage
Comment Définir des Filtres Prédéfinis
Exclure les Fichiers, Dossiers


Filtrer des fichiers par nom

Filtrage par Nom

Vous pouvez exclure des dossiers ou des fichiers en vous basant sur leurs noms ou en utilisant un ou plusieurs masques de fichier. Dans le champ Filtres de la barre d'outils, séparez les masques de fichiers avec des points-virgules. Ou bien, sélectionnez Filtres de fichiers [image] dans le menu Session et entrez chaque masque de fichier sur une ligne séparée.

Masque de fichier
Un masque de fichier est une chaîne modèle (pattern) de caractères et de caractères génériques utilisée pour trouvez des noms de dossier et de fichier.

Exemple : *.* trouvera n'importe quel nom de fichier. Pour des raisons historiques, il trouvera même les fichiers qui n'ont pas d'extension.
Exemple : *.html trouvera n'importe quel nom de fichier HTML.

Caractères Génériques
Les Caractères Génériques permettent à un masque de fichier de trouver de multiples noms de fichier ou de dossier.

? Correspond à un seul caractère.
* Correspond à 0 ou n'importe quel autre nombre de caractères.
[az] Correspond à un caractère à l'intérieur de l'ensemble, a ou z.
[a-z] Correspond à tout caractère dans la plage, de a à z.
[!az] Correspond à tout caractère non à l'intérieur de l'ensemble, ni a ou z.

Exemple : A? correspondra à A suivi de tout caractère unique.
Exemple : A* correspondra à A suivi de n'importe quel nombre de caractères.
Exemple : [a-z0-9] correspondra à n'importe quel chiffre ou lettre.
Exemple : [!ac-g] correspondra à n'importe quel caractère excepté a, c, d, e, f et g.

Masques de fichier simple
Les masques de fichier simple affectent tous les fichiers et dossiers dont le dossier parent est inclus. Le dossier de base est toujours inclus. Tous les dossiers qui contiennent des fichiers inclus sont aussi inclus.

Pour exclure plutôt qu'inclure les items spécifiés, ajoutez un singe moins (-) en tête du masque de fichier dans le champs Filtres. Dans le dialogue des Filtres de Fichier, placez le masque de fichier dans le champ Exclure au lieu d'utiliser le signe moins.

f Inclut tout fichier nommé f.
p\ Inclut tout dossier nommé p.
-f Exclut tout fichier nommé f.
-p\ Exclut tout dossier nommé p.

Exemple : *.pas;*.dfm;*dpr inclurait seulement les fichiers avec pas, dfm ou dpr comme extension.
Exemple : Source\ inclurait seulement les dossiers nommés Source et leurs sous-dossiers.
Exemple : -*.dcu;-*.ddp exclurait les fichiers avec dcu et ddp comme extension.
Exemple : -Sauvegarde\ exclurait les dossiers nommés Sauvegarde.

Masques de fichier relatif
Les masques de fichier relatif affecte les fichiers et les dossiers qui sont dans des endroits spécifiques.

p\f f doit être dans le dossier p.
.\f f doit être dans le dossier de base.
...\f f peut avoir 0 ou plusieurs dossiers parent.

Exemple : Windows\*.txt affecterait n'importe quel fichier texte de n'importe quel dossier inclus nommé Windows.
Exemple : ...\Windows\*.txt affecterait n'importe quel fichier texte de n'importe quel dossier nommé Windows.
Exemple : .\Windows\*.txt affecterait n'importe quel fichier texte d'un dossier nommé Windows qui est dans le dossier de base.


Plus d'infos au sujet des couleurs de dossier

Plus d'Informations Sur les Couleurs des Dossiers

Un dossier rouge contient une différence quelque part dedans, un dossier bleu contient un orphelin quelque part de dans; etc. Les dossiers évidés sont en train d'être examinés en tâche de fond. Ils changent de couleurs dès que tous leurs sous-dossiers ont été balayés. Si vous avez décoché "Balayer automatiquement les sous-dossiers en arrière-plan", alors, leurs sous-dossiers resteront jaunes jusqu'à ce que vous les ouvriez.

Notez que les couleurs de dossier reflètent leur contenu -- sans tenir compte du filtre d'affichage courant. Par exemple, dans l'exemple suivant, nous avons sélectionné le filtre "Non orphelins", mais quelque dossiers sont colorés en bleu. Cela signifie que ces dossiers-là ont un dossier orphelin quelque part chez eux, bien que les fichiers orphelins ne soient pas affichés.

Les archives ZIP utilisent également les icônes colorées de dossier, mais avec un "z" dessus.


Paramètres FTP

Ouvrez Options dans le menu Outils et sélectionnez l'onglet FTP pour optimiser différents aspects de votre connexion FTP. Ces paramètres affecteront toutes les connexions FTP effectuées par Beyond Compare.

Votre adresse email
Lors d'une connexion à un site FTP anonyme, il est habituel de mettre votre adresse email comme mot de passe. Beyond Compare enverra ce qui est entré ici (quoi que ce soit) comme mot de passe lors de la connexion à des sites FTP anonymes.

Conversion de nom de fichier
 Plusieurs sites FTP sont sensibles à la casse, et traitent les fichiers qui ont le même nom mais une casse différentes comme des entités séparées. Lors de l'envoi vers des sites FTP, Beyond Compare peut modifier le nom du fichier envoyé afin qu'il corresponde à certaines conventions de nommage. Vous pouvez sélectionner Ne pas changer, minuscules ou MAJUSCULES. Ces modifications prendront place si un fichier de même nom, évidemment sans tenir compte de la casse, n'est pas déjà trouvé dans le répertoire cible.

Résolution de lien
 Les sites FTP peuvent connecter des fichiers ensembles en utilisant des "liens" ("links") qui pointent d'une zone du site vers une autre. Ces liens ne spécifient pas s'ils pointent vers des fichiers ou des dossiers, c'est pourquoi les méthodes de résolution suivantes sont disponibles :

  • Rapide Ne requiert aucun transfert supplémentaire. Tout lien qui a une extension (eg. '.txt') est considérée comme étant un fichier, et tous les autres sont considérés comme étant des dossiers.

  • Simple BC essaiera de modifier les liens en dossiers dès qu'il en rencontre un. En cas de succès, le lien est considéré comme un dossier; sinon, il est considéré comme un fichier.

  • Complet BC utilisera sa représentation interne de la structure FTP pour déterminer ce qu'est la cible. Cela détectera les liens rompus et pourra demander moins d'opérations que le mode "Simple", mais peut être pris dans liens récursifs

Délai de Lecture
 Fixe le temporisateur pour le téléchargement de fichier. L'opération échouera si aucun octet n'est reçu durant cet intervalle de temps.

Cache Local
 Afin de minimiser le nombre de fois que Beyond Compare a besoin de télécharger du site FTP, il garde une copie locale des fichiers récemment téléchargés. Lors de l'essai de téléchargement d'un nouveau fichier, Beyond Compare essaiera de conserver la taille du cache en dessous de cette valeur. Le cache est supprimé lorsque BC est fermé; les fichiers individuels qui y sont, sont supprimés lorsqu'ils sont modifiés sur le site FTP.

Options LIST
 Paramètres additionnels pour la commande LIST. Par exemple, -al montrera les éléments caché sur certains serveurs.

Prendre les Dates/Heures
 Essaie de récupérer l'heure de dernière modification du fichier dans le cas où la liste du répertoire ne fournit que la date. alors que ceci fournit des comparaisons de dates/heures plus précises, c'est au coût d'une certaine performance. Ce n'est pas supporté par tous les serveurs FTP.

Reconnexion Automatique
 Si nécessaire, reconnecte silencieusement une déconnexion suite à une temporisation.

Cacher les Numéros de Version VMS
 Uniquement la version la plus récente d'un fichier est incluse et s'alignera avec un fichier local. Si cette option n'est pas cochée, toutes les versions du fichier seront incluses avec leurs numéros de version, et elles ne s'aligneront pas avec les fichiers locaux.

Type de Transfert
 Les sites FTP peuvent transférer les données de deux façons : ASCII ou binaires. L'ASCII est utilisé pour transférer des fichiers texte qui n'ont aucun caractère spécial. Le serveur FTP fera automatiquement les ajustements de fin de ligne nécessaires au mode ASCII. Le mode Binaire est utilisé pour transférer tous les autres fichiers, incluant les images, la musique, les documents Word, etc. Dans le mode Binaire, aucune modification n'est effectuée au fichier pendant le transfert.

Positionner le type de transfert à Binaire ou à ASCII forcera le transfert de tous les fichiers dans ce mode. Si le type de transfert est Auto, Beyond Compare commutera automatiquement le mode en se basant sur l'extension de chaque fichier. Pour indiquer quels seront les fichiers à transférer en ASCII, ajouter et supprimer des extensions à la liste Envoyer en ASCII.

Paramètres de Pare-feu (Firewall) / Proxy
 Si votre connexion FTP a besoin de passer par un serveur Proxy (serveur "mandataire") avant de se connecter, vous devez saisir vos données ici. Beyond Compare supporte aussi bien SOCKS 4 que 5. Si vous avez besoin d'aide pour ces paramètres, consultez votre administrateur système.

Mode Passif (PASV)
 Quelques configuration de pare-feu requièrent ces paramètres qui modifient la méthode utilisée pour le transfert d'échange entre votre ordinateur et le serveur FTP. Tous les serveurs FTP ne supportent pas le mode PASV. Si la connexion se gèle, essayez de cocher ce paramètre

Utiliser le pare-feu
Spécifie que les connexions FTP doivent utiliser le protocole Proxy FTP. Si vous n'êtes pas sur un réseau local (LAN) ou un réseau WAN, laissez cette option non-cochée.


Spécifications FTP

Vous pouvez tapez directement une spécification FTP dans le champ Répertoire de Base en utilisant la syntaxe :

  ftp://nomdutilisateur@ftp.nomdhôte.com

Le programme vous demandera le mot de passe si nécessaire. Ou bien, vous pouvez inclure le mot de passe dans la spécification :

  ftp://nomdutilisateur:motdepasse@ftp.nomdhôte.com

Laissez vide le nom d'utilisateur pour un accès anonyme :

  ftp://ftp.nomdhôte.com

Vous pouvez spécifier une dossier relatif au dossier de connexion :

  ftp://nomdutilisateur@ftp.nomdhôte.com/sousdossier

...ou relativement au dossier racine du site :

  ftp://nomdutilisateur@ftp.nomdhôte.com//sousdossier


CRC

Un CRC ("Cyclic Redundancy Check", Test de Redondance Cyclique) est une représentation numérique du contenu d'un fichier. Si le CRC de deux fichiers sont différents, alors les contenus de ces fichiers doivent être différents. Si les CRC sont égaux, alors il y a de fortes chances que leurs contenus soient identiques.


Terminaison de Ligne (Fin de Ligne)

Les fichiers texte contiennent normalement des caractères de contrôle invisibles qui indiquent la fin de chaque ligne. Différents système d'exploitation utilisent différentes conventions pour ces caractères de contrôle. Par exemple, les fichiers texte Windows ont normalement un retour chariot (CR, Carriage Return, code ASCII 13) et un saut de ligne (LF, Line Feed, code ASCII 10) à la fin de chaque ligne. Mais Unix utilise les sauts de lignes seuls pour les fins de ligne. Quelques applications produisent des fichiers en sortie qui utilisent uniquement un retour chariot, ou dans certains cas obscurs un saut de ligne suivi par un retour chariot.

La situation est bien plus compliquée lorsqu'un fichier issu à l'origine d'un système Unix a été changé par une station de travail Windows, et termine avec un mélange de différentes fins de ligne dans le même fichier.

Beyond Compare est conçu pour être tolérant aux différents styles de fin de ligne. Dans le Visualiseur de Fichier, vous pouvez comparer côte-à-côte un fichier qui utilise un certain style à un fichier qui utilise un style différent. Ainsi, l'option de "comparaison de contenu basée sur des règles" vous permet de comparer des fichiers texte dans le Visualiseur de Fichier, en ignorant les différences de fin de ligne.


Localiser Votre Site Web

Si vous souhaitez traduire votre site Web dans une autre langue, vous pouvez utiliser Beyond Compare pour gérer la traduction.

Le programme est fourni avec un définition prédéfinie de règles associées aux fichiers *.htm et *.html. vous pouvez créer une nouvelle définition de règles pour mieux gérer les comparaisons des pages traduites par rapport aux pages originales :

  1. Sélectionnez Options dans le menu Outils et allez à la page des Règles.
  2. Cliquez sur Nouvelle et acceptez Visualiseur de Fichier comme gestionnaire. La boîte de dialogue des Règles de Comparaison apparaîtra.
  3. Entrez "Traductions HTML" dans le champ Nom, et *.htm;*.html dans le champ Associée avec.
  4. Allez à l'onglet Importance et autorisez toutes les options pour les espaces blancs.
  5. Dans la section Chaînes de caractère littérales, cliquez sur Nouvelle, en entrez "<" dans le champ Commençant par et ">" dans le champ Finissant par. Cliquez sur OK.
  6. Autorisez également l'option Tout autre texte n'est pas important.

Avec cette définition de règles, le texte traduit sera considéré comme "non important" et sera coloré en bleu, tandis que tout changement dans les étiquettes (tags) sera considéré comme important et coloré en rouge. Ceci rend facile l'apparence des modifications accidentelles dans les étiquettes (tags).

Le traducteur peut utiliser Beyond Compare comme un éditeur de texte pour la traduction, en travaillant avec les deux langues côte-à-côte. Et plus tard, lorsque les changements seront effectués sur le site, le traducteur pourra utiliser Beyond Compare pour identifier ce qui a été changé, en combinant les changements structurels dans la copie localisée, et y ajouter un nouveau texte.


Gérer les Règles de Comparaison de Fichiers

Dans le menu Outils, cliquez sur Options et choisissez la page Règles. Là, vous pouvez voir et gérer la liste entière des règles définies.

L'ordre de la liste est important. Lorsque Beyond Compare recherche l'ensemble des règles à utiliser pour un fichier, il balaye la liste depuis le haut jusqu'en bas, en s'arrêtant à la première correspondance du champ Type de Fichier. Si un item est indiqué en rouge, cela signifie que des items antérieurs correspondent déjà au type de fichier, de telle sorte que cet item ne sera jamais automatiquement sélectionné (bien que vous pouvez sélectionner n'importe quel item manuellement). Pour changer l'ordre dans la liste, sélectionnez un item et cliquez sur Monter ou Descendre. Vous devriez avoir une définition "Prendre tout" en base de la liste, définition associée avec *.*.

Lorsque vous ouvrez le Visualiseur de Fichier, le programme sélectionne automatiquement les règles à utiliser, règles basées sur les noms de fichiers. Pour changer les règles à partir du Visualiseur de Fichier, sélectionnez Choisir les règles [image] ou Modifier les règles actuelles dans le menu Outils.

Beyond Compare vient avec des règles préconfigurées pour les types de fichiers courants. Vous pouvez les modifier ou en ajouter. La plupart des définitions de règle seront basées sur le Visualiseur de Fichier inclus, décrit ici. Vous pouvez aussi avoir des définitions de règles pour les visualiseurs sous forme de modules d'extensions (plug-ins), tels que le visualiseur hexadécimal (Hex Viewer).

Le dialogue des Règles de Comparaison de Fichiers a quatre onglets pour modifier les options :
Options Générales
Options d'Importance
Options d'Alignement
Options de Conversion


Gérer les Fenêtres Multiples

Lorsque vous avez le Visualiseur de Dossier et une ou plusieurs fenêtres d'ouvertes dans le Visualiseur de Fichier, vous pouvez commuter entre elles avec les commandes Fenêtre suivante (Ctrl+Tab) et Fenêtre précédente.

Les fenêtres du Visualiseur de Fichier peuvent être minimisées indépendamment, mais minimiser le Visualiseur de Dossier minimisera toutes les fenêtres.

Le menu Fenêtre comporte également des commandes pour gérer le positionnement des fenêtres du Visualiseur de Fichier : Organiser les fenêtres Horizontalement, Organiser les fenêtres Verticalement et Affichage en Cascade.


Filtre par date, autres filtres

Pour éditer les filtres de fichiers, sélectionnez Filtres de Fichier [image] dans le menu Session.

L'onglet Filtre par Date vous permet d'exclure des fichiers dont la date/heure est plus ancienne ou plus récente qu'une date/heure limite spécifiée. Cette date limite est soit une date spécifique ainsi qu'une heure, ou un nombre de jours relatif à la date système courante à 0h.

L'onglet Autres Filtres contrôle les filtres d'attribut de taille.

Le positionnement d'Attributs vous permet d'exclure des fichiers en se basant sur le fait qu'ils ont ou non les attributs Archive, Système, Caché ou Lecture seulement. Si un attribut Inclure est coché, les fichiers doivent avoir cet attribut pour être inclus. Les fichiers avec des attributs Exclure seront exclus.

L'affectation de la Taille vous permet d'exclure les fichiers dont la taille en octets est plus petite ou plus grande qu'une taille limite spécifiée.

Si un fichier d'un côté doit être caché, mais le fichier de l'autre côté doit être visible, les deux seront visibles et celui qui aurait dû être caché apparaîtra coloré en bleu-vert.

Les filtres effectifs par date, attribut et taille sont indiqués sur un panneau qui apparaît dans le Visualiseur de Dossiers.


Déplacer des Fichiers, Dossiers

Sur le menu Actions, la commande Déplacer [image] déplace les fichiers et dossiers sélectionnés d'un côté de l'affichage vers l'autre, écrasant tout fichier existant dans le côté cible.

Si un dossier est sélectionné, son contenu sera déplacé en entier, sans tenir compte des filtres de fichiers ni des filtres d'affichage. Toutefois, si un dossier ouvert est sélectionné, et si ses enfants sont également sélectionnés, alors la sélection du dossier est ignorée et seuls les enfants sélectionnés seront déplacés.

Par défaut, une demande de confirmation apparaîtra avant le déplacement. Pour sauter la confirmation, ouvrez le menu Outils, cliquez sur Options, allez à l'onglet Confirmations, et décochez Confirmer le déplacement de fichier


Ouvrir avec

La commande Ouvrir avec est située dans le menu Actions du Visualiseur de Dossier et dans le menu Fichier du Visualiseur de Fichier. Elle vous permet d'ouvrir les fichiers avec une autre application que celle qui est associée à son type de fichier. Ouvrir avec fonctionne avec les fichiers locaux et les disques réseaux, mais pas avec les sites FTP, ni avec les fichiers zip.

Le sous-menu d'Ouvrir avec contient :

  • Explorer (si un dossier unique est sélectionné)
  • Application associée (si un fichier unique est sélectionné)
  • Les autres applications que vous avez configurées
  • Tous les visualiseurs de BC et des modules d'extension (plug-ins)

Explorer ouvre le dossier sélectionné dans une nouvelle fenêtre de l'Explorateur.

Application associée ouvre le fichier sélectionné comme si vous aviez double-cliqué sur lui dans la fenêtre de l'Explorateur. Les fichiers exécutables s'exécutent directement, et les autres fichiers sont ouverts avec leur association Windows.

Pour configurer les applications qui doivent apparaître dans le sous-menu, sélectionnez Options dans le menu Outils, et choisissez la page Ouvrir avec. Cliquez sur Nouvelle et suivez les instructions pour spécifier la ligne de commande pour invoquer l'application.

Le sous-menu liste également tous les visualiseurs de Beyond Compare et les modules d'extension (plug-ins), ainsi vous pouvez en sélectionner un ce qui n'est normalement pas associé avec ce type de fichier.


Rafraîchir par rapport à Rafraîchir Complètement

Rafraîchir [image] re-lit tous les dossiers ouverts, et met à jour la liste actuelle. Si un fichier a été modifié, ajouté ou supprimé, la liste est corrigée, et les couples d'items correspondants sont recomparés si nécessaire. Rafraîchir laisse tous les paramètres existants tels quels, les dossiers ouverts, les sélections telles quelles, et ne recompare que les items qui ont été modifiés.

Rafraîchir Complètement [image] est une opération plus lourde qui oublie complètement toute comparaison existante de dossiers. Il devra se reconnecter aux sites FTP, rebalayer tous les dossiers, et recomparer tout. Il conserve les paramètres de la session intacts, mais tous les dossiers ouverts seront fermés et votre sélection disparaîtra. C'est sa première utilité si vous souhaitez forcer la recomparaison de tout et si Beyond Compare n'a pas détecté correctement un changement dans le système de fichiers ou sur un site FTP.


Renommage via Expressions Régulières

Pour renommer des fichiers en utilisant les Expressions Régulières compatibles Perl, sélectionnez un fichier dans le Visualiseur de Dossier et sélectionner Renommer [image] du menu Actions. Sélectionne Expressions Régulières de la boîte de dialogue Renommer. Dans la zone Ancien Nom, entrez une expression régulière qui correspond au nom original du fichier. Dans la zone Nouveau Nom, entrez un modèle à utiliser pour générer un nouveau nom de fichier.

Un modèle est une expression utilisée avec l'expression régulière définie dans la zone de l'ancien nom pour créer un nouveau nom.

Exemple - Changement Partiel de Nom :

Si "ABCDEF" est le nom du fichier, et si vous souhaitez changer "CD" en "HJ", entrez "CD" dans la zone de l'Ancien Nom et "HJ" dans la zone du Nouveau Nom. Le nouveau nom de fichier sera "ABHJEF".

Exemple - Changement Complet de Nom :

Si "Beyond" est le nom du fichier, et si vous souhaitez le changer en "Scooter", entrez ".*" dans la zone Ancien Nom, et "Scooter" dans la zone Nouveau Nom.

Vous pouvez également changer le nom du fichier en entrant "Beyond" dans la zone Ancien Nom et "Scooter" dans la zone Nouveau Nom. Toutefois, pour des renommages simples, il est plus facile d'utiliser le Renommage DOS.

Exemple - Changer un Groupe de Nom de Fichiers

Si vous avez un groupe de fichiers texte avec des noms de six lettres, e si vous souhaitez permuter les trois premières lettres avec les trois dernières, entrez "(...)(...).txt" dans la zone Ancien Nom et "$2$1.txt" dans la zone Nouveau Nom. Dans ce cas, "beyond.txt" deviendra "ondbey.txt".

Un autre exemple est si vous avez un groupe de fichiers musicaux qui sont nommés "Artiste-Chanson" et que vous souhaitez les changer en "Artiste - Chanson", entrez "-" dans la zone Ancien Nom et " - " dans la zone Nouveau Nom.


Expressions Régulières

Les Expressions Régulières sont une façon puissante de définir des modèles de recherches et d'appariements. Beyond Compare vous permet d'utiliser des expressions régulières lors de recherche dans du texte, et lors de la spécification de règles pour classifier les textes. Le support d'expressions régulières dans Beyond Compare est un sous-ensemble de la syntaxe Perl des Expressions Régulières (PCRE, Perl Compatible Regular Expression).

Une expression régulière est composée de deux types de caractère, les caractères normaux, et les méta-caractères. Lors de l'exécution de recherche d'égalité, les méta-caractères ont une signification spéciale pour contrôler comment le test d'égalité sera fait, et sert de joker (caractère générique). Les caractères normaux sont toujours comparés tels quels. Pour comparer à un méta-caractère, dégagez-vous de sa signification en le préfixant avec un barre renversée '\' (Caractère d'échappement, "Escape"). Il y a de nombreux types de méta-caractères, chacun étant détaillé ci-dessous.

Méta-caractères - Séquences d'échappement :

  • \xnn caractère dont le code hexadécimal est nn
  • \x{nnnn} caractère dont le code hexadécimal est nnnn
  • \t tabulation (0x09)
  • \n nouvelle ligne (0x0A)
  • \r retour chariot (0x0D)
  • \f saut de page (0x0C)
  • \a bip (0x07)
  • \e ESC, Échap. (0x1B)

Méta-caractères - Classes prédéfinies :

Les classes prédéfinies de caractère s'apparient avec n'importe quel caractère d'un certain sous-ensemble. Les classes suivantes sont déjà définies pour vous.

  • . représente n'importe quel caractère
  • \w tout caractère alphanumérique ou _
  • \W tout caractère non alphanumérique
  • \d tout caractère numérique (0-9)
  • \D tout caractère non numérique
  • \s tout espace non significatif (espace, tabulation, retour chariot)

Vous pouvez construire vos propres classes en entourant le groupe de caractères entre crochets "[]". Les classes prédéfinies (excepté '.') peuvent être utilisées entre crochets, et si un tiret '-' apparaît entre deux caractères, cela représente un intervalle. Donc [a-z] représente toutes les lettres minuscules, et [a-zA-Z] représentera les lettres minuscules et majuscules. Pour inclure un '-' dans la classe, placez-le au début ou à la fin de la chaîne de caractères.

Si le premier caractère entre les crochets est un accent circonflexe "^", alors la classe représente tous les caractères exceptés ceux qui sont spécifiés. [^a-z] représente tous les caractères qui ne sont pas des caractères alphabétiques minuscules.

Méta-caractères - Alternatives :

En plaçant un '|' entre deux groupes d'items, on indique des concordances alternatives. a|b concordera avec a ou b. ab|cd concordera avec "ab" ou "cd", mais pas "ac". "|" groupe les caractères à partir du délimiteur du modèle ("(", "[" ou le début du modèle) jusqu'à lui-même, et ensuite jusqu'à la fin du modèle. Des alternatives peuvent être placées entre parenthèses "()" pour faire en sorte que ce qu'on recherche soit évident, comme dans a(bc|de]f. Les alternatives sont appariées de gauche à droite; bey|beyond concordera avec bey, même si la chaîne de caractères est "beyond".

Méta-caractères - Ancrages (Positions) :

Les méta-caractères suivants contrôlent lorsque l'appariement doit être sur une ligne. Notez : \A et \Z concorde avec respectivement le début et la fin du texte, mais Beyond Compare exécute la recherche sur la base d'une ligne, ceux-ci ont le même effet que ^ et $.

  • ^ concorde uniquement avec le début de la ligne
  • $ concorde uniquement avec la fin de la ligne

Méta-caractères - Répétitions :

N'importe quoi dans une expression régulière peut être suivi par un méta-caractère de répétition (opérateur itératif) qui s'applique à l'item précédent. Il y a deux sortes de répétition - Gourmande ou non gourmande. Les répétitions gourmandes s'apparient avec autant de caractères qu'elles peuvent, les non gourmandes avec aussi peu qu'elles peuvent.

Gourmande :

  • * désigne zéro ou plusieurs fois le caractère précédent (équivalent à {0,})
  • + désigne une ou plusieurs fois le caractère précédent (équivalent à {1,})
  • ? désigne zéro ou une fois (équivalent à {0,1})
  • {n} désigne exactement n fois (équivalent à {n,n})
  • {n,} désigne n ou plusieurs fois
  • {n,m} désigne au moins n mais pas plus que m fois

Non Gourmande :

  • *? désigne zéro ou plusieurs fois
  • +? désigne une ou plusieurs fois
  • ?? désigne zéro ou une fois
  • {n}? désigne exactement n fois
  • {n,}? désigne au moins n fois
  • {n,m} désigne au moins n mais pas plus que m fois

Méta-Caractères - Sous-expressions :

Les parenthèses "()" peuvent également être utilisées pour grouper des caractères afin de les utiliser avec des itérations et des références arrières (discutées ci-dessous). (bey){4,5} désignera entre 4 et 5 fois les occurrences de "bey". (abc|[0-9])* désigne n'importe quelle combinaison de "abc" et de chiffres 0 à 9. Eg. "abc5", "679abc" et "abc77abc".

Méta-Caractères - Références Arrières :

Chaque séquence de caractères qui concorde dans un groupe "()" sera sauvegardée comme une sous-expression à laquelle vous pourrez vous référer plus tard avec \1 à \9, qui se réfèrent aux sous-expressions de gauche à droite. b(.)\1n concordera avec "been" et "boon", mais pas avec "bean", ni "ben" ou "beeen".

Modificateurs :

Les modificateurs vous permettent de modifier le comportement de l'appariement à partir de ce point. Si le modificateur est contenu dans une sous-expression, il affecte uniquement cette sous-expression. Les modificateurs sont représenté par (?x) ou (?-x) où x est la lettre modificatrice, et la présence de '-' indique si la fonctionnalité doit être prise en compte ou non.

Exemples :

(?i)Beyond Compare concorde avec "Beyond Compare" et avec "beyond compare"

(?i)Beyond (?-i)Compare concorde avec "Beyond Compare" et "bEyOnD Compare", mais pas avec "beyond compare"


Renommer des Fichiers et des Dossiers

Dans le menu Actions, la commande Renommer [image] renomme les fichiers et dossiers sélectionnés.

Dans la sous-section Action, vous pouvez sélectionner Compatible DOS ou Expressions Régulières. Compatible DOS étend les caractères génériques en utilisant les règles du DOS. Expressions Régulières utilise les expressions régulières compatibles Perl.

Renommage DOS

Si de multiples fichiers ou dossiers sont sélectionnés, un masque de base qui représente l'intersection de tous les noms est calculé. Un astérisque (*) est utilisé pour représenter un ou plusieurs caractères, tandis qu'un point d'interrogation (?) est utilisé pour représenter un caractère unique. Laissez ces caractères tels quels, mais changez les autres pour produire des noms uniques pour chacun des fichiers ou dossiers sélectionnés.

Exemple :

Si les fichiers suivants sont sélectionnés, l'Ancien Nom sera "abc?.txt".

     abc1.txt
     abc2.txt
     abc3.txt

Si vous changez le Nouveau Nom en "abc?.bak", alors les fichiers seront renommés en :

     abc1.bak
     abc2.bak
     abc3.bak

Ou, en changeant le Nouveau Nom en "xyz?.txt", les fichiers seront renommés en :

     xyz1.txt
     xyz2.txt
     xyz3.txt


Codes de Rapport

Les codes de rapport sont formés de deux chiffres pour le style d'édition suivis par une lettre indiquant le filtre actif. Exemple : 50n indique une comparaison côte-à-côte de dossiers des fichiers qui sont plus récents à gauche.

Style de Rapport des Différences entre Fichiers :
 00 Dessus/dessous
01 Côte-à-côte
02 Côte-à-côte, pas de numéro de ligne
03 Composant
04 Réparation (Patch)
05 Statistiques

Filtres d'Édition de Différences entre Fichiers:
 a Toutes les lignes
d Uniquement les différences
s Uniquement les différences importantes
m Uniquement le texte différent

Style de Rapport de Comparaison de Dossiers :
 50 Côte-à-côte
51 Liste résumée

Style de Rapport de Comparaison de Dossiers :
 a Tous les fichiers
d Uniquement les différences
m Uniquement les égalités
b Pas d'orphelin
z Les différences, mais pas les orphelins
s Uniquement les orphelins
n Les plus récents du côté gauche
o Les plus récents du côté droit
u Les plus récents du côté gauche et les orphelins
v Les plus récents du côté droit et les orphelins


Comparaison de Contenus Basée sur des Règles

Lorsque vous sélectionnez Comparaison basée sur des règles dans les paramètres des critères de comparaison, le Visualiseur de Dossier balayera automatiquement chaque couple de fichiers, utilisant les règles de comparaison de fichiers associées avec le type de fichier. Les règles définissent quel texte est important et lequel n'est pas important. Une comparaison basée sur des règles est également exécutée lorsque vous ouvrez un couple de fichiers dans le Visualiseur de Fichier, ou quand vous utilisez la commande d'action Comparer les Contenus.

Les résultats de la comparaison de contenus sont indiqués par une icône dans la colonne centrale du Visualiseur de Dossier.

Résultat | Icône | Lorsque...
Exact |  | le contenu est identique
Différent |  | des différences importantes sont trouvées
Similaire |  | des différences sont trouvées, mais uniquement dans du texte non important

Ces résultats se superposent aux autres critères de comparaison et peuvent changer l'affichage du Visualiseur de Dossier. Si une comparaison basée sur des règles résulte en une égalité, les items seront traités comme des égalités exactes dans le Visualiseur de Dossier. Ils seront colorés en noir, même si leur date/heure ou leur taille diffèrent. Réciproquement, les dates/heures et les tailles peuvent être exactement égales, mais si une différence importante est trouvée, les items seront colorés en rouge.

Notez que les items peuvent disparaître de l'affichage pendant leur comparaison. Par exemple, supposons qu'un couple de fichiers aient des dates différentes, mais que leur contenu soit identique. Initialement, avant que leur contenu ne soit comparé, ils apparaîtront comme des différences dans le Visualiseur de Dossier. Si vous avez le filtre d'affichage Uniquement les différences [image] qui est effectif, et exécutez une comparaison de contenus sur ces fichiers, ils disparaîtront de l'affichage dès que Beyond Compare aura déterminé que, en fait, ils sont identiques.

Lorsque l'option Ignorer les différences non importantes [image] n'est pas mise, des fichiers texte "similaires" seront traités comme des différences. Lorsque cette option est positionnée, les fichiers similaires seront traités comme des égalités exactes. Cela rend plus facile la détection des différences importantes dans de grandes arborescences de dossiers, sans avoir les différences non importantes dans les pieds.


Règles de Comparaison de Fichier - Alignement

Les options de l'onglet Alignement sont les suivantes :

Alignement de ligne
Les paramètres pour l'alignement des lignes contrôlent comment les égalités et les inégalités sont trouvées dans les fichiers.

Méthode Standard
Aligne les fichiers en comparant des fenêtres plus petites de chaque fichier. Tant que de bonnes concordances sont trouvées, l'alignement précédent est montré, et les positions des fenêtres sont mises à jour. Comme des parties d'alignement peuvent être montrées avant que l'alignement complet soit terminé, cette option est spécialement bonne pour de gros fichiers.

Ascenseur
Cela fournit un moyen facile de positionner les options "Tolérance de Synchronisation" et "Aligner les lignes similaires".

Tolérance de synchronisation
Le nombre de lignes de la fenêtre de comparaison. En comparant des fichiers contenant beaucoup d'insertions ou de changements, une grande valeur peut améliorer l'alignement. En comparant des fichier avec beaucoup de texte concordant, modifier cette valeur n'aura habituellement pas d'effet significatif sur l'alignement.

Aligner les lignes similaires
Compare les non-concordances et aligne les lignes modifiées mais similaires. Lorsque actif, un poids basé sur leurs similarités est donné aux non-concordances, et les "meilleures" concordances sont alignées même si ce ne sont pas des concordances exactes. Cette valeur peut améliorer drastiquement 'alignement des fichiers avec des modifications importantes, mais accroît le temps de comparaison et/ou produits des concordances invalides.

Méthode Alternative
Aligne les fichiers en comparant les deux fichiers complètement par l'utilisation d'un algorithme différent. Ceci peut donner de meilleures concordances pour certains type de changements tels que de grandes insertions ou lorsqu'un fichier contient beaucoup de texte répétitif. Comme les fichiers sont comparés entièrement en une seule fois, les balayage de gros fichiers prennent plus de temps que la méthode standard, et les fichiers ne sont pas affiché tant que la comparaison n'est pas finie. Cela ne supporte pas les comparaisons similaires, donc les non-concordances seront groupées en blocs.

Ne jamais aligner les différences
Montre les lignes non-concordantes comme des blocs de texte ajouté ou supprimé, au lieu de modifications.

Alignement des caractères
Après la fin de l'alignement, les lignes concordantes sont comparées pour montrer les différences dans chaque ligne.

Simple
Trouve la première et la dernière différence et marque tout ce qui se trouve entre comme une non-concordance. Cette méthode est plus rapide que la méthode standard, mais elle produit des alignements de plus mauvaise qualité.

Standard
Aligne les caractères concordants et ensuite marque les caractères ajoutés, supprimés et changé comme des non-concordances.

Base sur une colonne
Compare chaque caractère à la même position dans la ligne opposée et marque les concordances et les non-concordances comme appariées.

Poids des lignes
Le poids des lignes affecte la méthode d'alignement de ligne "Standard" en encourageant ou décourageant les alignements de ligne individuelle. Chaque paire de concordance exacte reçoit un poids particulier, ensuite les concordance et les plages de concordance avec le poids le plus fort reçoivent la préférence. Des suites de concordances consécutives peuvent compter comme un poids unique supérieur.

Le poids par défaut des lignes avec du texte important est de 20, et le défaut pour les lignes avec uniquement du texte non important est de 10. Si une concordance ou une suite de concordances atteint un poids de 5000, il est considéré comme assez bon et est immédiatement aligné. Des poids de 500 ou 1000 encouragera fortement une concordance bien que permettra des non-alignements dans des cas extrêmes.

Expression
Expression régulière représentant le poids de la ligne. N'importe quelle ligne qui concorde cette expression recevra le poids associé. L'expression de ne doit pas nécessairement concorder avec la ligne entière.

Poids
Poids qui seraient assignés aux concordances exactes.


Règles de Comparaison de Fichier - Conversion

Les options de l'onglet Conversion sont les suivantes :

Type de conversion
Avant d'exécuter une comparaison basée sur des règles ou visuelle, Beyond Compare peut effectuer différentes actions telles que la conversion de fichier en texte, ou la suppression d'informations superflues.

Détection des types gérés
Détecte les fichiers que Beyond Compare peut traiter automatiquement. Parce qu'uniquement les fichiers binaires Delphi DFM ont un support intégré, ils seront convertis vers et à partir de texte automatiquement tandis que les fichiers non supportés seront balayés inchangés.

Aucune conversion
Empêche les conversions automatiques.

Enlever le formatage de texte enrichi (RTF)
Enlève la police, la disposition et tout autre information non textuelle des fichiers de texte enrichi (RTF). Les paragraphes seront formatés avec retour automatique à la ligne basé sur le paramètre Général "Longueur maximale de ligne". Les fichier non RTF ne seront pas changés. Cela améliore les comparaisons visuelles, mais comme de l'information est perdue pendant la conversion, l'édition est interdite.

Programme externe
Exécute un programme externe de conversion avant de charger la comparaison et/ou lors de la sauvegarde des changements.

Conversion binaire des DFM
Beyond Compare peut détecter les fichiers binaires Form de Delphi et peut les convertir vers et à partir de texte automatiquement en les comparant. Les fichiers Delphi 1-7 sont traités automatiquement. Si le format changes dans une version ultérieure, placez le chemin d'accès vers le convert.exe de Delphi ici et BC l'utilisera au lieu du support intégré de BC.

Conversion externe
Utilise un programme externe pour convertir le fichier avant qu'il soit comparé et/ou avant qu'il soit sauvé. Les variables %s et %t peuvent être utilisées pour représenter les noms de fichier "source" et "destination". Le convertisseur doit pouvoir lire le fichier à partir de %s et l'écrire vers %t. Des guillemets seront ajoutés automatiquement si nécessaires. Le répertoire de travail sera le répertoire d'installation de Beyond Compare, ainsi l'information du chemin d'accès ne sera pas nécessaire si le convertisseur est stocké dans ce répertoire.

Exécution lors du chargement
Ligne de commande à exécuter avant que la comparaison s'installe.

Le cas simple est quand le convertisseur prend une paire de noms de fichiers telle que "convert.exe %s %t".

Pour rediriger l'entrée standard ou la sortie standard, créer un fichier de commande (batch) que BC appellera, et le convertisseur sera appelé à partir de ce fichier de commande.

Pour utiliser l'automatisation COM, utiliser les scripts Windows (Windows Scripting Host). Par exemple, voyez les règles externes de MSWord sur notre site Web.

Lecture seule
Empêche la modification du fichier converti.

Exécution lors de la sauvegarde
Ligne de commande pour convertir la version texte vers son format original.


Règles de Comparaison de Fichier - Général

Les options de l'onglet Général sont les suivantes :

Nom
Titre descriptif.

Associé avec
Liste des types de fichiers auxquels cette règle s'applique. Des types multiples peuvent être inclus en les séparant avec un point-virgule. Les masques peuvent être aussi spécifiques que nécessaire (eg. "BC2*.ini"), mais les masques ne peuvent pas contenir d'information de chemin d'accès.

Inclut les espaces blancs
Ces paramètres contrôlent quels caractères sont considérés comme étant des espaces pendant la comparaison.

Uniquement les espaces
Les tabulations seront traitées comme des caractères non imprimables et ne seront pas étendues en espaces.

Tabulations et espaces
Les tabulations seront traitées comme des espaces blancs et seront étendues en espaces en se basant sur le paramètre Tabulation.

Fins de ligne
Windows, MacOS et Unix utilisent différents caractères pour indiquer une fin de ligne. Normalement, le type de caractère de fin de ligne est ignoré, et des lignes avec des terminaisons différentes seront considérées comme concordantes. Ce paramètre-ci supplante ce comportement et compare les fins de ligne. Pour voir la différence, utilisez la commande "Montrer les espaces blancs".

Longueur maximale de ligne
De quelle longueur une ligne peut-elle être avant qu'elle soit rebouclée de force. Ce paramètre utilise le rebouclage de caractère au lieu du rebouclage de mots, de cette façon, il peut couper les lignes au milieu d'un mots. Le rebouclage est effectué avant la comparaison, et peut exiger un réalignement parce qu'il peut affecter une renumérotation de ligne. Alors que la longueur de ligne défaut est de 4096, elle peut être augmentée jusqu'à 8192, mais il y aura peut-être.

Jeu de caractères
L'encodage des caractères des fichiers. Il y a plusieurs façons de stocker les caractères dans un fichier, et ce paramètre contrôle comment ces caractères sont traités. "ANSI", la valeur par défaut, est le standard d'encodage utilisé par Windows et est dépendant des paramètres régionaux de l'ordinateur. "OEM" représente un encodage similaire utilisé par le DOS. "UTF-8" et "Unicode" sont des standards d'encodage qui peuvent stocker des textes de plus d'un langage, et qui seront identiques sur tous les ordinateurs. Lorsque c'est possible, UTF-8 et Unicode seront détecté automatiquement. "Demande lors du chargement" demandera l'encodage lors du chargement pour la comparaison visuelle, autorisant les comparaisons de fichiers de différents encodages.

Ctrl+Z indique la fin de fichier
Quelques éditeurs DOS utilise le caractère Ctrl+Z pour marquer la fin d'un fichier. Si le Visualiseur de Fichier montre des "crasses" après la fin de votre fichier, ce paramètre peut aider à éliminer ces caractères "insolites". Ne l'utilisez pas pour des comparaisons de fichiers binaires.


Règles de Comparaison de Fichier - Importance

Les options de l'onglet Importance sont les suivantes :

Texte non important
Ce paramètre contrôle quel texte Beyond Compare considère comme important en comparant des fichiers. Des différences dans du texte non importants sont marquées comme "similaires" au lieu de différentes, et seront montrées avec du bleu (par défaut) au lieu de rouge. En utilisant l'option "Ignorer les différences non importantes" dans les comparaisons de fichier et de dossier marquera les différences non importantes comme des concordance exactes, les colorant et filtrant comme telles.

Casse de caractère (ABC = abc)
Contrôle si les différences de caractères sont importantes.

NOTE : Contrairement aux autres catégories de texte non important, ceci affecte le texte dans les chaînes de caractères littérales.

Espaces blancs de début
Contrôle quand une espace en début de ligne est non important.

Espaces blancs intérieurs
Contrôle quand une espace en milieu de ligne est non important.

Espaces blancs de fin
Contrôle quand une espace en fin de ligne est non important.

Fins de ligne
Contrôle quand les fins de ligne sont non importantes. Ceci ne peut être coché que si l'option "Fins de ligne" de l'onglet Général est également cochée.

Lignes blanches
Contrôle lorsque les lignes sans texte ou seulement avec du texte non important sont considérées comme non importantes.

Personnalisation
En plus des paramètres ci-dessus, vous pouvez marquer certaines catégories de texte comme non important ou des chaînes de caractères littérales en utilisant des classifications personnalisées.

Délimité
Marque tout le texte à partir du délimiteur de début jusqu'au délimiteur de fin comme non important ou comme une chaîne de caractères littérale. Le texte délimité peut soit continuer jusqu'à ce que le délimiteur de fin soit trouvé, ou stopper à la fin de la ligne courante. Les délimiteurs ne peuvent pas inclure de caractères génériques ni dépasser la fin d'une ligne, de plus, ils sont sensibles à la casse. Le texte entre les délimiteurs peuvent être à cheval sur plusieurs lignes.

Caractère d'échappement
Un caractère unique qui indique que le caractère le suivant ne fait pas partie du délimiteur de fin ni n'est un caractère d'échappement. Lorsqu'une concordance du délimiteur de fin est trouvée, le caractère immédiatement avant ce dernier est testé. Si ce caractère est un caractère d'échappement, le balayage continue à la recherche du prochain délimiteur de fin.

Expression Régulière
Marque tout le texte qui concorde avec l'expression régulière comme non important ou comme une chaîne de caractères littérale. Le texte concordant ne peut pas être à cheval sur plusieurs lignes.

Colonnes
Marque tout le texte dans la plage de colonnes comme non important ou comme une chaîne de caractères littérale. Le premier caractère de chaque ligne est en colonne 1, et la plage est inclusive.

Entêtes de Page
Marque un certain nombre de lignes au début de chaque "page" comme non importantes ou comme une chaîne de caractères littérale. Les pages restantes sont séparée par le caractère de saut de page.

Chaînes de caractères littérales
Le texte des chaînes de caractères littérales est considéré comme important même s'il concorde avec une des classifications de Texte Non Important. Par exemple, des espaces blancs dans une chaîne de caractères littérale sont considérés comme importants même si "Espaces intérieurs blancs" est cochée.

Les catégories de chaînes de caractères littérales sont identiques à celles des textes non importants. Lorsque des lignes sont concordantes par rapport aux délimiteurs, le délimiteur le plus extérieur est prioritaire, ainsi, une chaîne de caractères dans un commentaire sera considéré comme non importante, et un commentaire dans une chaîne de caractères sera considérée comme important.

Tout autre texte n'est pas important
Marque tout le texte en dehors des chaînes de caractères littérales comme non important. Normalement, tout texte qui n'est pas non important ou dans une chaîne de caractères est important. Ce paramètre marque ce texte comme non important à la place.


Exemple d'Expressions Régulières
Expression | Signification
^abc | Représente "abc" en début de ligne
abc$ | Représente "abc" à la fin de la ligne
^abc$ | Représente exactement la ligne "abc"
^\s*abc | Représente "abc" au début de la ligne, mais autorise des espaces blancs
^\s*end;?\s*$ | Représente une ligne contenant uniquement "end" ou "end;" avec des espaces blancs au début ou à la fin

Caractères de Contrôle utilisés dans les exemples précédents

Caractère | Signification
^ | Début de ligne
$ | Fin de ligne
\s | Espaces blancs (une tabulation ou un espace)
* | Zéro or plusieurs fois le caractère précédent
? | Caractère précédent optionnel

Voir également
 Expressions Régulières


Exemple d'Utilisations de Beyond Compare

Les gens utilisent Beyond Compare pour une grande variété de tâches. Voici quelques exemples :

Fusion des modifications de code source
Vérification de Copies
Conserver les Dossiers Synchronisés
Gérer un site Web via FTP
Récupérer les Dommages de Virus ou autres
Observer les Modifications dans le Temps


Sauver l'Instantané

Dans le menu Actions, la commande Sauver l'Instantané [image] sauvegarde une liste en lecture seule du dossier spécifié ainsi que de ses sous-dossiers, en y incluant la date/heure de chaque fichier, sa taille et ses attributs de fichier. Cochez les case appropriées pour également y inclure les CRCs calculés pour le contenu de chaque fichier, les données de version ou le contenu explicite du zip. Ces options rendront la création de l'instantané plus longue, mais le résultat sera plus complet.

Uniquement le côté gauche, uniquement le côté droit, ou le chemin d'accès entier peut être utilisé. Après que Démarrage aie été cliqué, une boîte de dialogue demandera le nom du fichier vers lequel sera sauvegardé l'instantané. Sauver l'Instantané construit alors la liste du dossier fourni, en y incluant tous les sous-dossiers, et la sauve en format compressé dans un fichier dont l'extension est .bcss. Les filtres d'affichage sont ignorés lors de la production de l'instantané. Si vous avez positionné des filtres de fichiers, mais que vous souhaitez inclure tous les fichiers, cochez l'option Ignorer les filtres.

Utiliser les Instantanés
Les instantanés sont utiles pour détecter les changements dans le temps. Les fichiers Instantanés peuvent être chargés ultérieurement et être comparés à un dossier actuel à ce moment.

Vous pouvez charger un Instantané exactement comme n'importe quel dossier de base. Les comparaisons binaires et basées sur des règles ne fonctionnent pas avec les Instantanés puisque les fichiers dans les Instantanés n'existent pas réellement. Si les CRC des fichiers sont sauvegardés, alors la comparaison de CRC peut être utilisée pour déterminer si le contenu de fichiers a été modifié.

Un Instantané se rappelle le nom du dossier de base d'où il a été produit. Si vous chargez un Instantané sur la ligne de commande (ou le déposez sur l'icône de Beyond Compare), le programme le comparera automatiquement à son dossier original.


Restauration Sélective de Fichier

Voici une histoire réelle. Un de nos client a été touché par la tempête Nimda (virus), infectant leur serveur IIS. Il a modifié ("défacé") plusieurs pages Web, et a infecté quelques exécutables. Après avoir arrêté le serveur, et restauré une sauvegarde du disque système dans un sous-dossier d'un autre disque, l'Administrateur Système (AS) a utilisé BC pour comparer le site actuel avec la sauvegarde :

  1. Spécifiez les chemins racine du site actuel et de la copie de sauvegarde.
  2. Cliquez sur Uniquement les différences [image].
  3. Cliquez sur Étendre tout [image].

BC a affiché rapidement tous les fichiers qui avaient été changés depuis la nuit précédente. En ouvrant des fichiers spécifiques, l'AS a pu voir comment la tempête avait changé le code HTML. BC a également montré les nombreux exécutables infectés parce qu'ils avaient une date/heure différente, ainsi qu'un accroissement de taille.

  1. Entrez "*.html;*.exe;*.com" pour le filtre de fichiers pour limiter l'affichage uniquement aux fichiers HTML et aux exécutables différents.
  2. Cliquez Sélectionner tous les fichiers et ensuite Copier à gauche pour restaurer rapidement les dizaines de fichiers endommagés.
  3. Remettez le filtre à "*.*" et cliquez sur Uniquement les orphelins.
  4. Supprimez sélectivement les exécutables de la tempête et les fichiers associés

Comme test final, il a utilisé BC pour regarder les fichiers qui auraient pu être corrompus sans avoir de modification de leur date/heure et de leur taille :

  1. Sélectionnez le filtre d'affichage Uniquement les égalités.
  2. Cliquez sur Sélectionner tous les fichiers.
  3. Sélectionnez Comparer les contenus [image] et cochez Comparaison binaire.

Le rapport résultant a montré que tous les fichiers inchangés depuis la sauvegarde étaient en fait identiques.

Ce fut une question de quelques minutes après la fin de la restauration de la bande (magnétique), la copie "en direct" était revenue à l'état normal, et de nouveau disponible en ligne, sans affecter aucun des changements légitimes effectués après la sauvegarde. Toutes les commandes utilisées dans cette situation sont disponibles dans la barre d'outils de la fenêtre principale d'affichage des dossiers.


Plus d'Informations sur les Sessions

Pour voir tous les paramètres qui sont associés à une session, sélectionnez Gestionnaire de Session [image] depuis le menu Session.

Lorsque vous avez une session, elle se souvient de ses paramètres, et les restaure la prochaine fois que vous appeler cette session. Si vous changez les paramètres de session et sortez du programme, les paramètres actuels sont sauvegardés comme une session appelée <sans titre>. Cette session <sans titre> est la session par défaut pour la prochaine fois que le programme sera exécuté, mais elle est effacée aussitôt qu'une autre session (nommée) est sélectionnée.

Dès que vous changez les dossiers de base (sans changer les sessions), le programme se rappellera la précédente comparaison des dossier. Vous pouvez utiliser les boutons Précédent [image] et Suivant [image] pour revenir rapidement à une comparaison précédente de dossiers. La mémoire En arrière / En avant est nettoyée lorsque vous sélectionnez une session nommée différemment.

Dans le Gestionnaire de session, vous pouvez verrouiller une session sauvegardée de telle sorte qu'elle ne puisse pas être changée ou supprimée accidentellement. Sélectionnez une session et cliquez Verrouiller pour la verrouiller ou Déverrouiller pour la déverrouiller. Si vous ouvrez une session verrouillée et changez n'importe quel paramètre de sessions, vous ne pourrez pas la sauvegarder sous le même nom de session. Lorsque vous quitterez la session, les changements seront oubliés sans l'habituel demande "Voulez-vous sauvegarder les modifications de la session ?".

Voir également
Les paramètres par défaut de Session
Partager les Sessions


Définir les Critères de Comparaison
  1. Dans le menu Session, sélectionnez Contrôle de comparaison [image].
  2. Dans l'onglet Général sous Critères de comparaison, modifiiez les paramètres comme vous le souhaitez.

Rubriques apparentées
Détails des Critères


Positionner l'Extension de Contexte
  1. Dans la menu Outils du Visualiseur de Fichier, sélectionnez Options.
  2. Dans l'onglet Visualiseur de Fichier, modifiez Nombre de lignes de contexte comme souhaité.


Partager BC en réseau

Partager BC Enregistré sur un Réseau

Suivez ces étapes pour distribuer Beyond Compare aux utilisateurs de votre réseau :

  1. Placez une copie du programme d'installation de BC2 (eg. beycmpfr.exe) sur votre réseau.
  2. Créez un fichier texte nommé "BC2.key" dans le même endroit réseau et collez-y votre clé de licence. Également, copiez tous les modules d'extension / plug-ins (*.bcp) que souhaitent avoir vos utilisateurs dans ce même répertoire.

Lorsqu'un utilisateur exécute le programme d'installation à partir de cet endroit, il copiera automatiquement le fichier de la clé de licence vers leur système et BC sera enregistré.

Si vous souhaitez, vous pouvez avoir des utilisateurs qui exécutent le programme d'installation avec l'option "/silent". Il n'y aura qu'une seule confirmation et ensuite Beyond Compare sera installé sans autre interaction.

Options de la Ligne de Commande du Programme d'Installation

Nous utilisons Inno Setup de Jordan Russell (www.innosetup.com) pour le programme d'installation. Voici la documentation complète pour les commutateurs de ligne de commande :

/SP-
Empêche la question "Ceci va installer... Voulez-vous continuer ?" au début de l'Installation.
/SILENT, /VERYSILENT
Force l'Installation d'être silencieuse ou très silencieuse. Lorsque l'Installation est silencieuse, l'assistant et la fenêtre en arrière-plan ne sera pas affichée mais la fenêtre de progression sera montrée. Lorsque l'Installation est très silencieuse, la fenêtre de progression ne sera pas affichée. Tout le reste sera normal comme pour les messages d'erreur pendant l'installation qui seront affichés, et la demande de démarrage qui sera montrée (si vous ne l'avez pas empêché avec l'option '/SP-' comme expliqué ci-dessus).

Si un redémarrage est nécessaire, que la commande '/NORESTART' n'est pas utilisée (voir ci-dessous) et que l'Installation est silencieuse, elle affichera le message "Voulez-vous redémarrer maintenant ?". Si elle est très silencieuse, elle redémarrera sans le demander.
/NOCANCEL
Empêche l'utilisateur d'annuler pendant le processus d'installation en désactivant le bouton Annuler et en ignorant les clics sur le bouton de fermeture. Utile lorsque employé avec /SILENT.
/NORESTART
Combiné avec /SILENT ou /VERYSILENT, force l'Installation à ne pas redémarrer même si cela est nécessaire.
/LOADINF="nom de fichier"
Indique à l'Installation de charger les paramètres à partir du fichier "nom de fichier" après avoir testé la ligne de commande. Ce fichier peut être préparé en utilisant la command '/SAVEINF=' comme expliqué ci-dessous. N'oubliez pas d'utiliser des guillemets si le nom de fichier contient des espaces.
/SAVEINF="nom de fichier"
Indique à l'Installation de sauver les paramètres dans le fichier spécifié. N'oubliez pas d'utiliser des guillemets si le nom de fichier contient des espaces.
/DIR="x:\répertoire"
Remplace le nom de répertoire par défaut affiché sur la page "Sélectionnez un Répertoire de Destination" de l'Assistant. Un chemin d'accès entièrement qualifié doit être spécifié.
/GROUP="nom de dossier"
Remplace le nom de répertoire par défaut affiché sur la page "Sélectionnez un groupe de programmes" de l'assistant.
/NOICONS
Indique à l'Installation de tester initialement la case à cocher "Ne pas créer de groupe de programmes" sur la page "Sélectionnez un groupe de programmes" de l'assistant.


Partager des sessions

Partager les Sessions

Plusieurs utilisateurs pour partager des sessions en lecture seule en utilisant les fichiers de sessions partagé. Dans le menu Outils, choisissez Exporter les réglages pour créer un fichier de session partagée avec un sous-ensemble de vos sessions.

Pour utiliser un fichier de sessions partagées :

  1. Dans le menu Outils, cliquez sur Options.
  2. Sur la page du Visualiseur de Dossier, entrer l'adresse du Fichier de sessions partagées.


Partager votre Code

Chacun de nous qui travaillons au développement de Beyond Compare avons des dossiers séparés où nous travaillons indépendamment sur des parties différentes. Nous utilisons Beyond Compare (bien sûr) pour synchroniser de temps en temps nos efforts.

  1. Créez une session nommée avec les deux dossiers comme dossiers de base, et positionnez les filtres de fichiers aux fichiers qui doivent être synchronisés.
  2. Sélectionnez Uniquement les différences [image] pour limiter l'affichage aux fichiers qui sont différents.
  3. Dans le Visualiseur de Dossier (la fenêtre principale de comparaison de dossiers) utilisez Ctrl+R ou Ctrl+L pour copier des fichiers entiers vers la droite ou vers la gauche.
  4. Double-cliquez sur chaque couple de fichiers qui diffèrent afin de voir les modifications spécifiques dans le Visualiseur de Fichier.
  5. Dans le Visualiseur de Fichier, utilisez Ctrl+N pour balayer pas à pas les modifications dans un fichier. Utiliser Ctrl+R ou Ctrl+L pour copier les sections sélectionnées vers la droite ou vers la gauche.

Habituellement, nous copions généralement les modifications à partir de plutôt que vers l'autre programmeur. Il peut être plus facile de trier la comparaison sur le colonne Modifié, afin de trouver rapidement le travail récent de l'autre programmeur.

Quand un programmeur a fini le développement d'une fonctionnalité particulière, l'autre programmeur peut fusionner uniquement les modifications, sans copier les fichiers entiers. C'est également une bonne méthode pour les développeurs de relire et de comprendre le travail de chacun.


Montrer les Propriétés

La commande Propriétés du menu Actions affiche les feuilles standard Windows de propriétés des fichiers ou dossiers sélectionnés.


Conseils pour l'Instantané

Créez un Instantané d'une archive importante et testez-le périodiquement pour voir s'il n'est pas corrompu ou affaibli ("bit fade"). Soyez sûr d'inclure les CRC dans les Instantanés.

Créez un Instantané pour servir de documentation commode et compacte pour une distribution via CD.

Créez un Instantané de vos dossiers Système pour enregistrer les versions spécifiques des dll et d'autres composants Système en cours d'utilisation. Soyez sûr d'y stocker les CRC et les informations de version.

Avant de créer un Instantané qui inclut les CRC d'un dossier qui contient une multitude de fichiers et de dossiers, vous pouvez souhaiter désactiver tout logiciel Anti-Virus qui s'exécute en tâche de fond. Un tel logiciel balayera probablement chaque fichier qui sera ajouté à l'Instantané, ceci prendra beaucoup de temps. Rappelez-vous de réactiver ce logiciel Anti-Virus une fois la prise de l'Instantané réalisée.


Stratégies pour Faire Apparaître les Différences FTP

Les sites FTP gèrent les dates/heures différemment des systèmes de fichiers locaux. Lorsque vous copiez un fichier entre des dossiers locaux, la date/heure de "dernière modification" ne change pas. Par contre, lors de la copie vers un site FTP, la date/heure du fichier est positionnée à la date/heure actuelle. Cela signifie que Beyond Compare ne peut pas détecter les différences de fichiers en se basant sur des dates/heures plus récentes ou plus anciennes. Après avoir copié un groupe de fichiers vers un site FTP, ils apparaissent comme "plus récents" que la copie locale, même si, en fait, ils sont identiques.

De plus, rappelez-vous que certains sites FTP stockent les fichiers d'une manière différente de Windows. Les lignes sont terminées par un simple caractère de saut de ligne au lieu de la combinaison retour chariot / saut de ligne de Windows. À cause de cela, la différence de taille de fichiers ne peut pas être une vraie indication d'une différence réelle. La Comparaison basée sur des règles de Beyond Compare ignorera automatiquement les différences de fin de ligne.

Voici deux stratégies pour gérer ces points :

1) Recopier les Dates/Heures

Après avoir copié un groupe de fichiers vers un site FTP, utilisez la commande Modifier les dates/heures ("Touch") de Beyond Compare pour modifier les dates/heures (Toucher) des fichiers locaux afin qu'ils correspondent à la copie FTP.

  1. Dans le menu Actions, sélectionnez Modifier les dates/heures [image].
  2. Choisissez le côté qui contient les fichiers locaux.
  3. Sélectionnez Copier les dates/heures à partir du côté opposé, et appuyez sur Démarrer.

La version 2.1 a une option pour réaliser cela automatiquement :

  1. Dans le menu Session, choisissez Contrôle de comparaison [image].
  2. Dans l'onglet Avancé, cochez l'option Modifier la date/heure des fichiers locaux lors de la copie vers un site FTP.

2) Utilisez Uniquement la Comparaison de Contenu

Une autre approche est d'utiliser la comparaison de contenu basée sur des règles pour déterminer les fichiers inégaux et ignorer en même temps les dates/heures. Cette méthode est précise, mais comme chaque fichier est téléchargé pour tester son contenu, elle peut être inappropriée pour de grands sites ou des connexions lentes.

  1. Dans le menu Session, Choisissez Contrôle de comparaison [image].
  2. Décochez l'option Comparer les dates/heures.
  3. Cochez Comparer les contenus, et sélectionnez Comparaison basée sur des règles.


Synchroniser les Dossiers

Il y a trois commandes qui vous aident à synchroniser les dossiers de base. Les commande Synchroniser vers la droite [image] et Synchroniser vers la gauche [image] offrent le chemin le plus rapide pour synchroniser un côté avec l'autre. La troisième commande, Synchronisation spécifique [image], vous permet de réaliser des synchronisations bidirectionnelles ou d'autres synchronisations spécialisées.

Par défaut, la commande Synchroniser vers la droite copiera les fichiers plus récents et orphelins du côté gauche vers le côté droit. Synchroniser vers la gauche copie dans l'autre direction. Pour changer la façon de travailler de ces commandes, sélectionner Options du menu Outils et sélectionnez Options de synchronisation. Par exemple, pour avoir une commande Synchroniser vers la droite qui supprime également les orphelins de droite, vous pouvez changer la valeur de Si le fichier est uniquement à droite par Supprimer à droite.

Modifier uniquement les fichiers visibles est cochée par défaut, et limite la synchronisation aux dossiers ouverts qui passent le filtre d'affichage. Par exemple, si le filtre d'affichage est Uniquement les plus récents du côté gauche, les orphelins ne seront pas visibles et donc ne seront pas copiés. Si vous décochez Modifier uniquement les fichiers visibles, alors tous les fichiers qui passent les filtres de fichiers seront synchronisés, en y incluant ceux qui sont dans les sous-dossiers.

Créer les dossiers vides spécifie quand il faut copier les dossiers qui n'ont pas de contenu, soit parce qu'ils sont réellement vides, soit parce que leur contenu est filtré.

Si Uniquement la sélection est cochée, alors uniquement les fichiers et dossiers sélectionnés seront synchronisés. Au contraire des autres opérations de fichiers, les commandes de synchronisation traitent toujours les sélections comme deux côtés.

Sélectionnez le Type de synchronisation à partir du contrôle de liste déroulante.


Toucher les Fichiers (Modification de la date/heure)

Dans le menu Actions, la commande Modifier les dates/heures [image] modifie le cachet de la poste (date/heure de dernière modification) des fichiers sélectionnés.

Si Copier les dates/heures à partir du coté opposé est sélectionné, alors des dates/heures des fichiers sélectionnés seront positionnés pour correspondre à ceux de l'autre côté. Si Mettre la date/heure à --> est utilisée, alors toutes les dates/heures peuvent être sélectionnées à partir du calendrier.

La sélection Défaut contrôle comment le calendrier est initialisé. Heure système actuelle initialisera le calendrier à la date/heure actuelle. Dernière modification se rappellera la dernière opération de modification de date/heure. La sélection Défaut initialise uniquement le calendrier -- vous pouvez encore le changer à n'importe quelle date ou heure.


Transporter les Sources

Si vous prenez habituellement un projet à votre domicile pour y travailler dessus, vous pouvez utiliser Beyond Compare pour copier les fichiers vers et d'une disquette ou un portable. Vous pouvez copier uniquement les fichiers qui ont été modifiés plutôt que le projet entier. Et, suite au codage de couleurs dans BC, il est plus difficile de copier accidentellement dans la mauvaise direction.

Si le projet déborde de la disquette, compressez-le en utilisant votre utilitaire favori de zip. Ensuite, BC travaillera avec le fichier zip comme si c'était un dossier, et vous permettra de comparer et de mettre à jour les fichiers individuellement.


Gestion de Site

Après avoir effectué des modifications de votre site Web, utilisez Beyond Compare pour mettre à jour votre site en ligne. Vous pouvez copier le site entier en une seule fois, ou uniquement les fichiers qui ont été modifiés. Comme revue finale avant l'envoi, vous pouvez ouvrir les fichiers HTML dans le Visualiseur de Fichier pour voir exactement ce qui a été modifié. Cliquez sur le bouton Voir comme une page Web [image] à droite de la zone qui affiche le nom du fichier pour visualiser la page dans le mode WYSIWYG (What You See Is What You Get : Ce que vous voyez c'est ce que vous obtiendrez).

Beyond Compare est également pratique pour effectuer des petites modifications rapides telles que la correction d'erreurs de frappe sur votre site. Vous pouvez ouvrir la page dans le Visualiseur de Fichier, faire la correction, et le sauvegarder simultanément vers le site en ligne, et dans votre dossier local.


Voir les Changements de la Base de Registre

Pour voir comment un événement (tel que l'installation d'une application) modifie la base de registre, vous pouvez exporter la base de registre avant et après l'événement, et ensuite utiliser Beyond Compare pour visualiser les différences.

Pour exporter la base de registre :

  1. Cliquez Démarrer, Exécuter et ensuite taper "regedit".
  2. Dans l'arborescence de la Base de Registre, sélectionnez Poste de Travail.
  3. Dans le menu Fichier, sélectionnez Exporter, saisissez un nom de fichier, et cliquez sur Enregistrer.

Le fichier résultant est un fichier texte libre avec l'extension .reg. (Ne double-cliquez pas sur ce fichier, sinon Windows le réimportera dans la base de registre.)

Pour comparer deux exportations de la base de registre :

  1. Mettez en surbrillance les deux fichiers dans l'Explorateur Windows, cliquez sur le bouton droit et sélectionnez Comparer. (Ceci suppose que vous avez installé l'extension shell de Beyond Compare).
  2. Le Visualiseur de Fichier de Beyond Compare s'ouvrira et affichera les deux versions côte-à-côte.
  3. Sélectionnez Uniquement les différences [image] comme filtre d'affichage.


Équivalents Web

Lorsque le Visualiseur de Fichier visualise directement à partir d'un site FTP, la première fois vous pouvez sélectionner Voir comme une page Web [image], Beyond Compare vous demandera l'URL équivalente Web. Entrez l'équivalent HTTP dans le dossier de base FTP. Par exemple, si vous accédez ftp.mondomaine.com/racineweb pour maintenir votre site Web www.mondomaine.com, et si votre dossier de base dans Beyond Compare est :

ftp.mondomaine.com/racineweb/projet

...alors entrez l'équivalent Web tel que :

http://www.mondomaine.com/projet/


Ce que Beyond Compare NE FAIT PAS

Beyond Compare ne peut pas comparer les documents MS Word, MS Excel ou Adobe PDF côte-à-côte. Ils ont des formats complexes et propriétaires que Beyond Compare ne peut pas comprendre. Toutefois, si vous sauvegarder en premier lieu des documents comme des fichiers texte, BC peut comparer leur contenu.

Beyond Compare ne fonctionne pas sur un Mac, du moins nativement. Des utilisateurs nous ont rapporté un certain succès en exécutant BC sous VirualPC. Pour les fans d'OS/2, BC peut être "relinké" (éditeur de liens) en utilisant Odin, avec peu de problèmes. Actuellement, nous n'avons pas de version Unix de BC, bien qu'il soit dans notre intention de développer une version Linux.

Beyond Compare ne fait pas de comparaison de trois ensembles, ni ne fusionne automatiquement le code source.